raven/base/lxqt/lxqt-notificationd/lxqt-notificationd-downgrade-kde.patch
2024-02-21 13:47:54 +06:00

33 lines
1.1 KiB
Diff

diff -Naur a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2023-11-05 17:44:38.000000000 +0600
+++ b/CMakeLists.txt 2023-11-06 18:04:54.080609321 +0600
@@ -16,7 +16,7 @@
option(UPDATE_TRANSLATIONS "Update source translation translations/*.ts files" OFF)
option(LXQT_NOTIFICATION_BUILD_TESTS "Build LXQt Notification tests" OFF)
-set(KF5_MINIMUM_VERSION "5.101.0")
+set(KF5_MINIMUM_VERSION "5.96.0")
set(LXQT_MINIMUM_VERSION "1.4.0")
set(QT_MINIMUM_VERSION "5.15.0")
diff -Naur a/src/notification.cpp b/src/notification.cpp
--- a/src/notification.cpp 2023-11-05 17:44:38.000000000 +0600
+++ b/src/notification.cpp 2023-11-06 18:06:39.804816626 +0600
@@ -33,7 +33,6 @@
#include <QDebug>
#include <XdgIcon>
#include <KWindowSystem/KWindowSystem>
-#include <KWindowSystem/KX11Extras>
#include <QMouseEvent>
#include <QPushButton>
#include <QStyle>
@@ -327,7 +326,7 @@
return;
}
- const auto ids = KX11Extras::stackingOrder();
+ const auto ids = KWindowSystem::stackingOrder();
for (const WId &i : ids)
{
KWindowInfo info = KWindowInfo(i, NET::WMName | NET::WMVisibleName);