33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
diff -Naur a/CMakeLists.txt b/CMakeLists.txt
|
|
--- a/CMakeLists.txt 2023-11-05 17:52:24.000000000 +0600
|
|
+++ b/CMakeLists.txt 2023-11-07 10:19:45.144114340 +0600
|
|
@@ -16,7 +16,7 @@
|
|
option(UPDATE_TRANSLATIONS "Update source translation translations/*.ts files" OFF)
|
|
|
|
set(LXQTBT_MINIMUM_VERSION "0.13.0")
|
|
-set(KF5_MINIMUM_VERSION "5.101.0")
|
|
+set(KF5_MINIMUM_VERSION "5.96.0")
|
|
set(LXQT_MINIMUM_VERSION "1.4.0")
|
|
set(QT_MINIMUM_VERSION "5.15.0")
|
|
|
|
diff -Naur a/src/idlenesswatcher.cpp b/src/idlenesswatcher.cpp
|
|
--- a/src/idlenesswatcher.cpp 2023-11-05 17:52:24.000000000 +0600
|
|
+++ b/src/idlenesswatcher.cpp 2023-11-07 10:20:39.853753021 +0600
|
|
@@ -30,7 +30,6 @@
|
|
#include <Solid/Device>
|
|
#include <Solid/Battery>
|
|
#include <KWindowSystem/KWindowSystem>
|
|
-#include <KWindowSystem/KX11Extras>
|
|
#include <KWindowSystem/KWindowInfo>
|
|
#include <QDebug>
|
|
#include <LXQt/lxqtnotification.h>
|
|
@@ -162,7 +161,7 @@
|
|
|
|
// check if disable Idleness when fullscreen is enabled
|
|
if (mPSettings.isDisableIdlenessWhenFullscreenEnabled()) {
|
|
- WId w = KX11Extras::activeWindow();
|
|
+ WId w = KWindowSystem::activeWindow();
|
|
KWindowInfo info(w, NET::WMState);
|
|
if (info.hasState(NET::FullScreen)) {
|
|
QTimer::singleShot(0, this, [] {
|