raven/extras/dovecot24/dovecot-2.4-defaultconfig.patch

144 lines
4.7 KiB
Diff

diff -Naur a/doc/conf.d/10-auth.conf b/doc/conf.d/10-auth.conf
--- a/doc/conf.d/10-auth.conf 1970-01-01 06:00:00.000000000 +0600
+++ b/doc/conf.d/10-auth.conf 2025-01-24 18:31:57.000000000 +0600
@@ -0,0 +1,7 @@
+# Enable pam by default
+passdb pam {
+}
+
+# Use system users
+userdb passwd {
+}
diff -Naur a/doc/conf.d/10-mail.conf b/doc/conf.d/10-mail.conf
--- a/doc/conf.d/10-mail.conf 1970-01-01 06:00:00.000000000 +0600
+++ b/doc/conf.d/10-mail.conf 2025-01-28 12:56:09.232653876 +0600
@@ -0,0 +1,10 @@
+mail_driver = maildir
+mail_home = %h
+mail_path = ~/mail
+mail_inbox_path = /var/mail/%n
+mailbox_list_utf8 = yes
+
+namespace inbox {
+ separator = /
+ inbox = yes
+}
diff -Naur a/doc/conf.d/10-ssl.conf b/doc/conf.d/10-ssl.conf
--- a/doc/conf.d/10-ssl.conf 1970-01-01 06:00:00.000000000 +0600
+++ b/doc/conf.d/10-ssl.conf 2025-01-28 12:59:33.616396297 +0600
@@ -0,0 +1,5 @@
+#ssl_server {
+# cert_file = /etc/pki/tls/certs/ssl-cert-snakeoil.pem
+# key_file = /etc/pki/tls/private/ssl-cert-snakeoil.key
+#}
+#ssl_cipher_list = PROFILE=SYSTEM
diff -Naur a/doc/conf.d/20-imap.conf b/doc/conf.d/20-imap.conf
--- a/doc/conf.d/20-imap.conf 1970-01-01 06:00:00.000000000 +0600
+++ b/doc/conf.d/20-imap.conf 2025-01-24 18:31:57.000000000 +0600
@@ -0,0 +1,4 @@
+# Enable IMAP protocol
+protocols {
+ imap = yes
+}
diff -Naur a/doc/conf.d/20-lmtp.conf b/doc/conf.d/20-lmtp.conf
--- a/doc/conf.d/20-lmtp.conf 1970-01-01 06:00:00.000000000 +0600
+++ b/doc/conf.d/20-lmtp.conf 2025-01-24 18:31:57.000000000 +0600
@@ -0,0 +1,4 @@
+# Enable LMTP protocol
+protocols {
+ lmtp = yes
+}
diff -Naur a/doc/conf.d/20-pop3.conf b/doc/conf.d/20-pop3.conf
--- a/doc/conf.d/20-pop3.conf 1970-01-01 06:00:00.000000000 +0600
+++ b/doc/conf.d/20-pop3.conf 2025-01-24 18:31:57.000000000 +0600
@@ -0,0 +1,4 @@
+# Enable POP3 protocol
+protocols {
+ pop3 = yes
+}
diff -Naur a/doc/conf.d/20-submission.conf b/doc/conf.d/20-submission.conf
--- a/doc/conf.d/20-submission.conf 1970-01-01 06:00:00.000000000 +0600
+++ b/doc/conf.d/20-submission.conf 2025-01-24 18:31:57.000000000 +0600
@@ -0,0 +1,4 @@
+# Enable Submission protocol
+protocols {
+ submission = yes
+}
diff -Naur a/doc/dovecot.conf.in b/doc/dovecot.conf.in
--- a/doc/dovecot.conf.in 2025-01-24 13:08:40.000000000 +0600
+++ b/doc/dovecot.conf.in 2025-01-28 13:00:53.279906125 +0600
@@ -4,47 +4,9 @@
# configuration file. It specifies the configuration syntax, the used setting
# names and the expected default values.
dovecot_config_version = @DOVECOT_CONFIG_VERSION@
-
-# Dovecot storage file format version. It specifies the oldest Dovecot version
-# that must be able to read files written by this Dovecot instance. The
-# intention is that when upgrading Dovecot cluster, this setting is first kept
-# as the old Dovecot version. Once the cluster is fully upgraded to a new
-# version and there is no intention to rollback to the old version anymore,
-# this version number can be increased.
dovecot_storage_version = @DOVECOT_CONFIG_VERSION@
-# The configuration below is a minimal configuration file using system user authentication.
-# See https://@DOVECOT_ASSET_URL@/configuration_manual/quick_configuration/
-
-!include_try conf.d/*.conf
-
-# Enable wanted protocols:
-protocols {
- imap = yes
- lmtp = yes
-}
-
-mail_home = /srv/mail/%{user}
-mail_driver = sdbox
-mail_path = ~/mail
-mail_uid = vmail
-mail_gid = vmail
+protocols =
-# By default first_valid_uid is 500. If your vmail user's UID is smaller,
-# you need to modify this:
-#first_valid_uid = uid-number-of-vmail-user
-
-namespace inbox {
- inbox = yes
- separator = /
-}
-
-# Authenticate as system users:
-passdb pam {
-}
-
-ssl_server {
- cert_file = /etc/dovecot/ssl-cert.pem
- key_file = /etc/dovecot/ssl-key.pem
-}
+!include_try conf.d/*.conf
diff -Naur a/doc/Makefile.am b/doc/Makefile.am
--- a/doc/Makefile.am 2025-01-24 13:08:40.000000000 +0600
+++ b/doc/Makefile.am 2025-01-28 13:52:14.611578403 +0600
@@ -27,6 +27,8 @@
$(INSTALL) -d $(DESTDIR)$(sysconfdir)/dovecot
test -e $(DESTDIR)$(sysconfdir)/dovecot/dovecot.conf || \
$(INSTALL) dovecot.conf $(DESTDIR)$(sysconfdir)/dovecot/dovecot.conf
+ $(INSTALL) -d $(DESTDIR)$(sysconfdir)/dovecot/conf.d
+ $(INSTALL) conf.d/* $(DESTDIR)$(sysconfdir)/dovecot/conf.d/
install-data-local:
$(MKDIR_P) $(DESTDIR)$(docdir); \
diff -Naur a/doc/Makefile.in b/doc/Makefile.in
--- a/doc/Makefile.in 2025-01-24 13:08:52.000000000 +0600
+++ b/doc/Makefile.in 2025-01-28 13:11:02.189159488 +0600
@@ -866,6 +866,8 @@
$(INSTALL) -d $(DESTDIR)$(sysconfdir)/dovecot
test -e $(DESTDIR)$(sysconfdir)/dovecot/dovecot.conf || \
$(INSTALL) dovecot.conf $(DESTDIR)$(sysconfdir)/dovecot/dovecot.conf
+ $(INSTALL) -d $(DESTDIR)$(sysconfdir)/dovecot/conf.d
+ $(INSTALL) conf.d/* $(DESTDIR)$(sysconfdir)/dovecot/conf.d/
install-data-local:
$(MKDIR_P) $(DESTDIR)$(docdir); \