20 lines
1.0 KiB
Diff
20 lines
1.0 KiB
Diff
Index: docker-ce-17.11.0-ce/components/engine/runc-69663f0bd4b60df09991c08812a60108003fa340/Makefile
|
|
===================================================================
|
|
--- docker-ce-17.11.0-ce.orig/components/engine/runc-69663f0bd4b60df09991c08812a60108003fa340/Makefile
|
|
+++ docker-ce-17.11.0-ce/components/engine/runc-69663f0bd4b60df09991c08812a60108003fa340/Makefile
|
|
@@ -12,8 +12,12 @@ GIT_BRANCH_CLEAN := $(shell echo $(GIT_B
|
|
RUNC_IMAGE := runc_dev$(if $(GIT_BRANCH_CLEAN),:$(GIT_BRANCH_CLEAN))
|
|
PROJECT := github.com/opencontainers/runc
|
|
BUILDTAGS := seccomp
|
|
-COMMIT_NO := $(shell git rev-parse HEAD 2> /dev/null || true)
|
|
-COMMIT := $(if $(shell git status --porcelain --untracked-files=no),"${COMMIT_NO}-dirty","${COMMIT_NO}")
|
|
+ifeq ($(GIT_COMMIT_OVERRIDE),)
|
|
+ COMMIT_NO := $(shell git rev-parse HEAD 2> /dev/null || true)
|
|
+ COMMIT := $(if $(shell git status --porcelain --untracked-files=no),"${COMMIT_NO}-dirty","${COMMIT_NO}")
|
|
+else
|
|
+ COMMIT := $(GIT_COMMIT_OVERRIDE)
|
|
+endif
|
|
|
|
MAN_DIR := $(CURDIR)/man/man8
|
|
MAN_PAGES = $(shell ls $(MAN_DIR)/*.8)
|