raven/base/python-PyInstaller/python-PyInstaller.spec
2024-02-21 13:47:54 +06:00

70 lines
2.0 KiB
RPMSpec

Name: python-PyInstaller
Version: 6.3.0
Release: 1%{dist}
Summary: Bundle a Python application and all its dependencies into a single package
License: GPL-2.0-only
URL: https://www.pyinstaller.org
Source: https://github.com/pyinstaller/pyinstaller/archive/refs/tags/v%{version}.tar.gz#/pyinstaller-%{version}.tar.gz
BuildRequires: gcc
BuildRequires: binutils
BuildRequires: pkgconfig
BuildRequires: pkgconfig(zlib)
BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools
BuildRequires: python%{python3_pkgversion}-rpm-macros
%description
PyInstaller bundles a Python application and all its dependencies into a single
package. The user can run the packaged app without installing a Python
interpreter or any modules.
%package -n python%{python3_pkgversion}-PyInstaller
Summary: Bundle a Python application and all its dependencies into a single package
Recommends: upx
%description -n python%{python3_pkgversion}-PyInstaller
PyInstaller bundles a Python application and all its dependencies into a single
package. The user can run the packaged app without installing a Python
interpreter or any modules.
%prep
%setup -q -n pyinstaller-%{version}
%autopatch -p1
chmod a-x PyInstaller/utils/hooks/__init__.py
# Force build of bootloader
rm -r PyInstaller/bootloader
%build
# -Wno-stringop-overflow only needed on ppc64
export CFLAGS="%{optflags} -Wno-stringop-truncation -Wno-unused-variable -Wno-unused-function -Wno-unused-but-set-variable -Wno-stringop-overflow"
%py3_build
%install
%py3_install
%ifnarch %ix86
mkdir -p %{buildroot}%{python3_sitearch}
mv %{buildroot}%{python3_sitelib}/* %{buildroot}%{python3_sitearch}
rm -fr %{buildroot}%{python3_sitelib}
%endif
%files -n python%{python3_pkgversion}-PyInstaller
%doc README.rst doc/CHANGES.rst
%license COPYING.txt
%{_bindir}/pyi-archive_viewer
%{_bindir}/pyi-bindepend
%{_bindir}/pyi-grab_version
%{_bindir}/pyi-makespec
%{_bindir}/pyi-set_version
%{_bindir}/pyinstaller
%{python3_sitearch}/*