diff -Naur libressl-3.8.1-orig/Makefile.am libressl-3.8.1/Makefile.am
--- libressl-3.8.1-orig/Makefile.am	2023-08-21 17:00:06.000000000 +0600
+++ libressl-3.8.1/Makefile.am	2023-10-03 14:13:45.763015193 +0600
@@ -12,7 +12,7 @@
 
 EXTRA_DIST = README.md README.windows VERSION config scripts
 EXTRA_DIST += CMakeLists.txt cmake_export_symbol.cmake cmake_uninstall.cmake.in FindLibreSSL.cmake LibreSSLConfig.cmake.in
-EXTRA_DIST += cert.pem openssl.cnf x509v3.cnf
+EXTRA_DIST += cert.pem libressl.cnf x509v3.cnf
 
 .PHONY: install_sw
 install_sw: install
@@ -24,7 +24,7 @@
 		OPENSSLDIR="$(DESTDIR)$(sysconfdir)/ssl"; \
 	fi; \
 	mkdir -p "$$OPENSSLDIR/certs"; \
-	for i in cert.pem openssl.cnf x509v3.cnf; do \
+	for i in cert.pem libressl.cnf x509v3.cnf; do \
 		if [ ! -f "$$OPENSSLDIR/$i" ]; then \
 			$(INSTALL) -m 644 "$(srcdir)/$$i" "$$OPENSSLDIR/$$i"; \
 		else \
@@ -38,7 +38,7 @@
 	else \
 		OPENSSLDIR="$(DESTDIR)$(sysconfdir)/ssl"; \
 	fi; \
-	for i in cert.pem openssl.cnf x509v3.cnf; do \
+	for i in cert.pem libressl.cnf x509v3.cnf; do \
 		if cmp -s "$$OPENSSLDIR/$$i" "$(srcdir)/$$i"; then \
 			rm -f "$$OPENSSLDIR/$$i"; \
 		fi \
diff -Naur libressl-3.8.1-orig/Makefile.in libressl-3.8.1/Makefile.in
--- libressl-3.8.1-orig/Makefile.in	2023-08-31 08:15:32.000000000 +0600
+++ libressl-3.8.1/Makefile.in	2023-10-03 14:14:15.117827061 +0600
@@ -374,7 +374,7 @@
 EXTRA_DIST = README.md README.windows VERSION config scripts \
 	CMakeLists.txt cmake_export_symbol.cmake \
 	cmake_uninstall.cmake.in FindLibreSSL.cmake \
-	LibreSSLConfig.cmake.in cert.pem openssl.cnf x509v3.cnf
+	LibreSSLConfig.cmake.in cert.pem libressl.cnf x509v3.cnf
 all: all-recursive
 
 .SUFFIXES:
@@ -895,7 +895,7 @@
 		OPENSSLDIR="$(DESTDIR)$(sysconfdir)/ssl"; \
 	fi; \
 	mkdir -p "$$OPENSSLDIR/certs"; \
-	for i in cert.pem openssl.cnf x509v3.cnf; do \
+	for i in cert.pem libressl.cnf x509v3.cnf; do \
 		if [ ! -f "$$OPENSSLDIR/$i" ]; then \
 			$(INSTALL) -m 644 "$(srcdir)/$$i" "$$OPENSSLDIR/$$i"; \
 		else \
@@ -909,7 +909,7 @@
 	else \
 		OPENSSLDIR="$(DESTDIR)$(sysconfdir)/ssl"; \
 	fi; \
-	for i in cert.pem openssl.cnf x509v3.cnf; do \
+	for i in cert.pem libressl.cnf x509v3.cnf; do \
 		if cmp -s "$$OPENSSLDIR/$$i" "$(srcdir)/$$i"; then \
 			rm -f "$$OPENSSLDIR/$$i"; \
 		fi \
diff -Naur libressl-3.8.1-orig/apps/openssl/apps.c libressl-3.8.1/apps/openssl/apps.c
--- libressl-3.8.1-orig/apps/openssl/apps.c	2023-08-21 16:50:37.000000000 +0600
+++ libressl-3.8.1/apps/openssl/apps.c	2023-10-03 14:15:00.235537604 +0600
@@ -1069,7 +1069,7 @@
 	const char *t = X509_get_default_cert_area();
 	char *p;
 
-	if (asprintf(&p, "%s/openssl.cnf", t) == -1)
+	if (asprintf(&p, "%s/libressl.cnf", t) == -1)
 		return NULL;
 	return p;
 }
diff -Naur libressl-3.8.1-orig/crypto/conf/conf_mod.c libressl-3.8.1/crypto/conf/conf_mod.c
--- libressl-3.8.1-orig/crypto/conf/conf_mod.c	2023-08-21 16:50:37.000000000 +0600
+++ libressl-3.8.1/crypto/conf/conf_mod.c	2023-10-03 14:15:27.230364281 +0600
@@ -474,7 +474,7 @@
 {
 	char *file = NULL;
 
-	if (asprintf(&file, "%s/openssl.cnf",
+	if (asprintf(&file, "%s/libressl.cnf",
 	    X509_get_default_cert_area()) == -1)
 		return (NULL);
 	return file;
diff -Naur libressl-3.8.1-orig/libressl.cnf libressl-3.8.1/libressl.cnf
--- libressl-3.8.1-orig/libressl.cnf	1970-01-01 06:00:00.000000000 +0600
+++ libressl-3.8.1/libressl.cnf	2023-07-05 14:08:27.000000000 +0600
@@ -0,0 +1,24 @@
+[ req ]
+#default_bits		= 2048
+#default_md		= sha256
+#default_keyfile 	= privkey.pem
+distinguished_name	= req_distinguished_name
+attributes		= req_attributes
+
+[ req_distinguished_name ]
+countryName			= Country Name (2 letter code)
+countryName_min			= 2
+countryName_max			= 2
+stateOrProvinceName		= State or Province Name (full name)
+localityName			= Locality Name (eg, city)
+0.organizationName		= Organization Name (eg, company)
+organizationalUnitName		= Organizational Unit Name (eg, section)
+commonName			= Common Name (eg, fully qualified host name)
+commonName_max			= 64
+emailAddress			= Email Address
+emailAddress_max		= 64
+
+[ req_attributes ]
+challengePassword		= A challenge password
+challengePassword_min		= 4
+challengePassword_max		= 20
diff -Naur libressl-3.8.1-orig/openssl.cnf libressl-3.8.1/openssl.cnf
--- libressl-3.8.1-orig/openssl.cnf	2023-07-05 14:08:27.000000000 +0600
+++ libressl-3.8.1/openssl.cnf	1970-01-01 06:00:00.000000000 +0600
@@ -1,24 +0,0 @@
-[ req ]
-#default_bits		= 2048
-#default_md		= sha256
-#default_keyfile 	= privkey.pem
-distinguished_name	= req_distinguished_name
-attributes		= req_attributes
-
-[ req_distinguished_name ]
-countryName			= Country Name (2 letter code)
-countryName_min			= 2
-countryName_max			= 2
-stateOrProvinceName		= State or Province Name (full name)
-localityName			= Locality Name (eg, city)
-0.organizationName		= Organization Name (eg, company)
-organizationalUnitName		= Organizational Unit Name (eg, section)
-commonName			= Common Name (eg, fully qualified host name)
-commonName_max			= 64
-emailAddress			= Email Address
-emailAddress_max		= 64
-
-[ req_attributes ]
-challengePassword		= A challenge password
-challengePassword_min		= 4
-challengePassword_max		= 20