clementine: 1.4.1-14
This commit is contained in:
parent
ba27fcd364
commit
ebcccd83bb
@ -1,15 +0,0 @@
|
||||
diff -Naur a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt 2023-10-02 08:31:59.000000000 +0600
|
||||
+++ b/CMakeLists.txt 2023-10-31 19:31:10.000000000 +0600
|
||||
@@ -354,6 +354,11 @@
|
||||
add_library(qtsingleapplication INTERFACE)
|
||||
target_link_libraries(qtsingleapplication INTERFACE QTSINGLEAPPLICATION_LIBRARIES)
|
||||
target_include_directories(qtsingleapplication INTERFACE QTSINGLEAPPLICATION_INCLUDE_DIRS)
|
||||
+ find_path(QTSINGLECOREAPPLICATION_INCLUDE_DIRS qtsinglecoreapplication.h PATH_SUFFIXES qt5/QtSolutions REQUIRED)
|
||||
+ find_library(QTSINGLECOREAPPLICATION_LIBRARIES Qt5Solutions_SingleCoreApplication-2.6 REQUIRED)
|
||||
+ add_library(qtsinglecoreapplication INTERFACE)
|
||||
+ target_link_libraries(qtsinglecoreapplication INTERFACE QTSINGLECOREAPPLICATION_LIBRARIES)
|
||||
+ target_include_directories(qtsinglecoreapplication INTERFACE QTSINGLECOREAPPLICATION_INCLUDE_DIRS)
|
||||
else(USE_SYSTEM_QTSINGLEAPPLICATION)
|
||||
add_subdirectory(3rdparty/qtsingleapplication)
|
||||
set(QTSINGLEAPPLICATION_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/qtsingleapplication)
|
@ -1,10 +1,10 @@
|
||||
%define git_rel 1
|
||||
%define git_rev g7b678f26e
|
||||
%define rc_num 901
|
||||
%define rc_tag rc1-%{rc_num}
|
||||
%define git_rev g39130c036
|
||||
%define rc_num 14
|
||||
#define rc_tag rc1
|
||||
|
||||
Name: clementine
|
||||
Version: 1.4.0
|
||||
Version: 1.4.1
|
||||
|
||||
Summary: A music player and library organizer
|
||||
|
||||
@ -43,11 +43,11 @@ License: GPL-3.0-or-later AND GPL-2.0-or-later AND BSL-1.0 AND LGPL-2.0-o
|
||||
|
||||
URL: https://www.clementine-player.org/
|
||||
%if 0%{?git_rel}
|
||||
Release: 12.rc1.%{rc_num}%{?dist}
|
||||
Source0: https://github.com/clementine-player/Clementine/archive/%{name}-%{version}%{rc_tag}-%{git_rev}.tar.xz
|
||||
Release: 0.1.%{rc_num}.%{git_rev}%{?dist}
|
||||
Source0: https://github.com/clementine-player/Clementine/releases/download/%{version}%{?rc_tag:-%{rc_tag}}-%{rc_num}-%{git_rev}/%{name}-%{version}%{?rc_tag:-%{rc_tag}}-%{rc_num}-%{git_rev}.tar.xz
|
||||
%else
|
||||
Release: 1%{?dist}
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
Source0: https://github.com/clementine-player/Clementine/archive/refs/tags/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
%endif
|
||||
|
||||
# Workaround for crash RHBZ#1566807
|
||||
@ -56,7 +56,7 @@ Source0: %{name}-%{version}.tar.gz
|
||||
Patch5: clementine-lastscope-size.patch
|
||||
# Use qt5 libraries (qtiocompressor)
|
||||
Patch10: 0001-Use-QtIoCompressor-from-Qt5.patch
|
||||
Patch11: clementine-qt5-libraries.patch
|
||||
|
||||
# Add system tray menu item to unhide the application
|
||||
Patch12: clementine-add-tray-item-to-unhide.patch
|
||||
# Patch fix build with recent protobuf
|
||||
@ -125,7 +125,6 @@ BuildRequires: qt5-linguist
|
||||
BuildRequires: qtiocompressor-devel
|
||||
BuildRequires: qtsingleapplication-qt5-devel >= 2.6.1-2
|
||||
BuildRequires: qtsinglecoreapplication-qt5-devel
|
||||
BuildRequires: sha2-devel
|
||||
%ifnarch s390 s390x
|
||||
BuildRequires: pkgconfig(libgpod-1.0)
|
||||
BuildRequires: pkgconfig(libimobiledevice-1.0)
|
||||
@ -147,9 +146,9 @@ music.
|
||||
|
||||
%prep
|
||||
%if 0%{?git_rel}
|
||||
%autosetup -p1 -n clementine-%{version}%{rc_tag}-%{git_rev}
|
||||
%autosetup -p1 -n clementine-%{version}%{?rc_tag:-%{rc_tag}}-%{rc_num}-%{git_rev}
|
||||
%else
|
||||
%autosetup -p1
|
||||
%autosetup -p1 -n Clementine-%{version}
|
||||
%endif
|
||||
|
||||
# Remove most 3rdparty libraries
|
||||
@ -208,6 +207,12 @@ appstream-util validate-relax --nonet %{buildroot}%{_metainfodir}/clementine.app
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Nov 22 2024 Raven <raven@sysadmins.ws> - 1.4.1-0.1.14.g39130c036
|
||||
- update to latest RC tag
|
||||
|
||||
* Fri Oct 18 2024 Raven <raven@sysadmins.ws> - 1.4.1-1
|
||||
- Update to 1.4.1
|
||||
|
||||
* Sun Dec 24 2023 Raven <raven@sysadmins.ws> - 1.4.0-12.rc1.901
|
||||
- rebuild for new protobuf
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user