ffmpeg: update to 7.1
This commit is contained in:
parent
5109161bd3
commit
5fc3d17acc
@ -21,62 +21,62 @@ diff --git a/configure b/configure
|
||||
index a54398c57f..dd7607731f 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -289,6 +289,7 @@ External library support:
|
||||
@@ -294,6 +294,7 @@
|
||||
--enable-libvorbis enable Vorbis en/decoding via libvorbis,
|
||||
native implementation exists [no]
|
||||
--enable-libvpx enable VP8 and VP9 de/encoding via libvpx [no]
|
||||
+ --enable-libsvtvp9 enable VP9 encoding via svt [no]
|
||||
--enable-libvvenc enable H.266/VVC encoding via vvenc [no]
|
||||
--enable-libwebp enable WebP encoding via libwebp [no]
|
||||
--enable-libx264 enable H.264 encoding via x264 [no]
|
||||
--enable-libx265 enable HEVC encoding via x265 [no]
|
||||
@@ -1848,6 +1849,7 @@ EXTERNAL_LIBRARY_LIST="
|
||||
libshaderc
|
||||
libshine
|
||||
libsmbclient
|
||||
@@ -1972,6 +1972,7 @@
|
||||
libvmaf
|
||||
libvorbis
|
||||
libvpx
|
||||
+ libsvtvp9
|
||||
libsnappy
|
||||
libsoxr
|
||||
libspeex
|
||||
@@ -3390,6 +3392,7 @@ libvpx_vp8_decoder_deps="libvpx"
|
||||
libvvenc
|
||||
libwebp
|
||||
libxevd
|
||||
@@ -3578,6 +3579,7 @@
|
||||
libvpx_vp8_encoder_deps="libvpx"
|
||||
libvpx_vp9_decoder_deps="libvpx"
|
||||
libvpx_vp9_encoder_deps="libvpx"
|
||||
+libsvt_vp9_encoder_deps="libsvtvp9"
|
||||
libvvenc_encoder_deps="libvvenc"
|
||||
libwebp_encoder_deps="libwebp"
|
||||
libwebp_anim_encoder_deps="libwebp"
|
||||
libx262_encoder_deps="libx262"
|
||||
@@ -6727,6 +6730,7 @@ enabled libvpx && {
|
||||
@@ -7041,6 +7043,7 @@
|
||||
fi
|
||||
}
|
||||
|
||||
+enabled libsvtvp9 && require_pkg_config libsvtvp9 SvtVp9Enc EbSvtVp9Enc.h eb_vp9_svt_init_handle
|
||||
enabled libvvenc && require_pkg_config libvvenc "libvvenc >= 1.6.1" "vvenc/vvenc.h" vvenc_get_version
|
||||
enabled libwebp && {
|
||||
enabled libwebp_encoder && require_pkg_config libwebp "libwebp >= 0.2.0" webp/encode.h WebPGetEncoderVersion
|
||||
enabled libwebp_anim_encoder && check_pkg_config libwebp_anim_encoder "libwebpmux >= 0.4.0" webp/mux.h WebPAnimEncoderOptionsInit; }
|
||||
diff --git a/libavcodec/Makefile b/libavcodec/Makefile
|
||||
index 9c38240025..1984cb970c 100644
|
||||
--- a/libavcodec/Makefile
|
||||
+++ b/libavcodec/Makefile
|
||||
@@ -1128,6 +1128,7 @@ OBJS-$(CONFIG_LIBVPX_VP8_DECODER) += libvpxdec.o
|
||||
@@ -1161,6 +1161,7 @@
|
||||
OBJS-$(CONFIG_LIBVPX_VP8_ENCODER) += libvpxenc.o
|
||||
OBJS-$(CONFIG_LIBVPX_VP9_DECODER) += libvpxdec.o
|
||||
OBJS-$(CONFIG_LIBVPX_VP9_ENCODER) += libvpxenc.o
|
||||
+OBJS-$(CONFIG_LIBSVT_VP9_ENCODER) += libsvt_vp9.o
|
||||
OBJS-$(CONFIG_LIBVVENC_ENCODER) += libvvenc.o
|
||||
OBJS-$(CONFIG_LIBWEBP_ENCODER) += libwebpenc_common.o libwebpenc.o
|
||||
OBJS-$(CONFIG_LIBWEBP_ANIM_ENCODER) += libwebpenc_common.o libwebpenc_animencoder.o
|
||||
OBJS-$(CONFIG_LIBX262_ENCODER) += libx264.o
|
||||
diff --git a/libavcodec/allcodecs.c b/libavcodec/allcodecs.c
|
||||
index 184bb8521f..bda526f755 100644
|
||||
--- a/libavcodec/allcodecs.c
|
||||
+++ b/libavcodec/allcodecs.c
|
||||
@@ -801,6 +801,7 @@ extern const FFCodec ff_libvpx_vp8_encoder;
|
||||
extern const FFCodec ff_libvpx_vp8_decoder;
|
||||
extern FFCodec ff_libvpx_vp9_encoder;
|
||||
extern const FFCodec ff_libvpx_vp9_decoder;
|
||||
+extern const FFCodec ff_libsvt_vp9_encoder;
|
||||
extern const FFCodec ff_libvvenc_encoder;
|
||||
/* preferred over libwebp */
|
||||
extern const FFCodec ff_libwebp_anim_encoder;
|
||||
extern const FFCodec ff_libwebp_encoder;
|
||||
|
||||
diff --git a/libavcodec/libsvt_vp9.c b/libavcodec/libsvt_vp9.c
|
||||
new file mode 100644
|
||||
index 0000000000..5f99367924
|
||||
|
@ -124,8 +124,8 @@ ExclusiveArch: armv7hnl
|
||||
|
||||
Summary: Digital VCR and streaming server
|
||||
Name: ffmpeg%{?flavor}
|
||||
Version: 7.0.2
|
||||
Release: 2%{?date:.%{?date}%{?date:git}%{?rel}}%{?dist}
|
||||
Version: 7.1
|
||||
Release: 12%{?date:.%{?date}%{?date:git}%{?rel}}%{?dist}
|
||||
License: %{ffmpeg_license}
|
||||
URL: https://ffmpeg.org/
|
||||
%if 0%{?date}
|
||||
@ -206,7 +206,7 @@ BuildRequires: libv4l-devel
|
||||
%{?!_without_vaapi:BuildRequires: libva-devel >= 0.31.0}
|
||||
BuildRequires: libvdpau-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
%{?_with_vapoursynth:BuildRequires: vapoursynth-devel}
|
||||
%{?_with_vapoursynth:BuildRequires: vapoursynth-devel >= 54}
|
||||
%{?!_without_vpx:BuildRequires: libvpx-devel >= 1.4.0}
|
||||
%{?_with_mfx:BuildRequires: pkgconfig(libmfx) >= 1.28}
|
||||
%ifarch %{ix86} x86_64
|
||||
@ -563,6 +563,9 @@ strip %{buildroot}%{_libdir}/%{name}/libavcodec.so.*
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jan 17 2025 Raven <raven@sysadmins.ws> - 7.1-1
|
||||
- Update to 7.1 release
|
||||
|
||||
* Mon Sep 9 2024 Raven <raven@sysadmins.ws> - 7.0.2-2
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user