httpd: update to 2.4.60
This commit is contained in:
parent
e01af796f9
commit
3c591a97aa
@ -1,93 +0,0 @@
|
|||||||
From d4e5b6e1e5585d341d1e51f1ddc637c099111076 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Joe Orton <jorton@redhat.com>
|
|
||||||
Date: Tue, 7 Jul 2020 09:48:01 +0100
|
|
||||||
Subject: [PATCH] Check and use gettid() directly with glibc 2.30+.
|
|
||||||
|
|
||||||
* configure.in: Check for gettid() and define HAVE_SYS_GETTID if
|
|
||||||
gettid() is only usable via syscall().
|
|
||||||
|
|
||||||
* server/log.c (log_tid): Use gettid() directly if available.
|
|
||||||
---
|
|
||||||
configure.in | 14 +++++++++-----
|
|
||||||
server/log.c | 8 ++++++--
|
|
||||||
2 files changed, 15 insertions(+), 7 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.in b/configure.in
|
|
||||||
index 423d58d4b9a..60cbf7b7f81 100644
|
|
||||||
--- httpd-2.4.43/configure.in.gettid
|
|
||||||
+++ httpd-2.4.43/configure.in
|
|
||||||
@@ -478,7 +500,8 @@
|
|
||||||
timegm \
|
|
||||||
getpgid \
|
|
||||||
fopen64 \
|
|
||||||
-getloadavg
|
|
||||||
+getloadavg \
|
|
||||||
+gettid
|
|
||||||
)
|
|
||||||
|
|
||||||
dnl confirm that a void pointer is large enough to store a long integer
|
|
||||||
@@ -489,16 +512,19 @@
|
|
||||||
APR_ADDTO(HTTPD_LIBS, [-lselinux])
|
|
||||||
])
|
|
||||||
|
|
||||||
-AC_CACHE_CHECK([for gettid()], ac_cv_gettid,
|
|
||||||
+if test $ac_cv_func_gettid = no; then
|
|
||||||
+ # On Linux before glibc 2.30, gettid() is only usable via syscall()
|
|
||||||
+ AC_CACHE_CHECK([for gettid() via syscall], ap_cv_gettid,
|
|
||||||
[AC_TRY_RUN(#define _GNU_SOURCE
|
|
||||||
#include <unistd.h>
|
|
||||||
#include <sys/syscall.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
int main(int argc, char **argv) {
|
|
||||||
pid_t t = syscall(SYS_gettid); return t == -1 ? 1 : 0; },
|
|
||||||
-[ac_cv_gettid=yes], [ac_cv_gettid=no], [ac_cv_gettid=no])])
|
|
||||||
-if test "$ac_cv_gettid" = "yes"; then
|
|
||||||
- AC_DEFINE(HAVE_GETTID, 1, [Define if you have gettid()])
|
|
||||||
+ [ap_cv_gettid=yes], [ap_cv_gettid=no], [ap_cv_gettid=no])])
|
|
||||||
+ if test "$ap_cv_gettid" = "yes"; then
|
|
||||||
+ AC_DEFINE(HAVE_SYS_GETTID, 1, [Define if you have gettid() via syscall()])
|
|
||||||
+ fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
dnl ## Check for the tm_gmtoff field in struct tm to get the timezone diffs
|
|
||||||
--- httpd-2.4.43/server/log.c.gettid
|
|
||||||
+++ httpd-2.4.43/server/log.c
|
|
||||||
@@ -55,7 +55,7 @@
|
|
||||||
#include "ap_mpm.h"
|
|
||||||
#include "ap_listen.h"
|
|
||||||
|
|
||||||
-#if HAVE_GETTID
|
|
||||||
+#if HAVE_SYS_GETTID
|
|
||||||
#include <sys/syscall.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
#endif
|
|
||||||
@@ -625,14 +625,18 @@
|
|
||||||
#if APR_HAS_THREADS
|
|
||||||
int result;
|
|
||||||
#endif
|
|
||||||
-#if HAVE_GETTID
|
|
||||||
+#if defined(HAVE_GETTID) || defined(HAVE_SYS_GETTID)
|
|
||||||
if (arg && *arg == 'g') {
|
|
||||||
+#ifdef HAVE_GETTID
|
|
||||||
+ pid_t tid = gettid();
|
|
||||||
+#else
|
|
||||||
pid_t tid = syscall(SYS_gettid);
|
|
||||||
+#endif
|
|
||||||
if (tid == -1)
|
|
||||||
return 0;
|
|
||||||
return apr_snprintf(buf, buflen, "%"APR_PID_T_FMT, tid);
|
|
||||||
}
|
|
||||||
-#endif
|
|
||||||
+#endif /* HAVE_GETTID || HAVE_SYS_GETTID */
|
|
||||||
#if APR_HAS_THREADS
|
|
||||||
if (ap_mpm_query(AP_MPMQ_IS_THREADED, &result) == APR_SUCCESS
|
|
||||||
&& result != AP_MPMQ_NOT_SUPPORTED)
|
|
||||||
@@ -966,7 +970,7 @@
|
|
||||||
#if APR_HAS_THREADS
|
|
||||||
field_start = len;
|
|
||||||
len += cpystrn(buf + len, ":tid ", buflen - len);
|
|
||||||
- item_len = log_tid(info, NULL, buf + len, buflen - len);
|
|
||||||
+ item_len = log_tid(info, "g", buf + len, buflen - len);
|
|
||||||
if (!item_len)
|
|
||||||
len = field_start;
|
|
||||||
else
|
|
@ -1,14 +0,0 @@
|
|||||||
|
|
||||||
Upstream-Status: not pushed upstream
|
|
||||||
|
|
||||||
--- httpd-2.4.54/server/log.c.gettid
|
|
||||||
+++ httpd-2.4.54/server/log.c
|
|
||||||
@@ -968,7 +972,7 @@
|
|
||||||
#if APR_HAS_THREADS
|
|
||||||
field_start = len;
|
|
||||||
len += cpystrn(buf + len, ":tid ", buflen - len);
|
|
||||||
- item_len = log_tid(info, NULL, buf + len, buflen - len);
|
|
||||||
+ item_len = log_tid(info, "g", buf + len, buflen - len);
|
|
||||||
if (!item_len)
|
|
||||||
len = field_start;
|
|
||||||
else
|
|
File diff suppressed because it is too large
Load Diff
@ -218,14 +218,6 @@ index e2e028a..5d1c0e1 100644
|
|||||||
int fd = find_systemd_socket(process, port);
|
int fd = find_systemd_socket(process, port);
|
||||||
if (fd < 0) {
|
if (fd < 0) {
|
||||||
return "Systemd socket activation is used, but this port is not "
|
return "Systemd socket activation is used, but this port is not "
|
||||||
@@ -438,7 +414,6 @@ static const char *set_systemd_listener(process_rec *process, apr_port_t port,
|
|
||||||
|
|
||||||
return NULL;
|
|
||||||
}
|
|
||||||
-
|
|
||||||
#endif /* HAVE_SYSTEMD */
|
|
||||||
|
|
||||||
static const char *alloc_listener(process_rec *process, const char *addr,
|
|
||||||
@@ -707,6 +682,9 @@ AP_DECLARE(int) ap_setup_listeners(server_rec *s)
|
@@ -707,6 +682,9 @@ AP_DECLARE(int) ap_setup_listeners(server_rec *s)
|
||||||
int num_listeners = 0;
|
int num_listeners = 0;
|
||||||
const char* proto;
|
const char* proto;
|
@ -100,7 +100,7 @@ index 5242c2a..e2e028a 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
#ifdef WIN32
|
#ifdef WIN32
|
||||||
@@ -315,6 +324,123 @@ static int find_listeners(ap_listen_rec **from, ap_listen_rec **to,
|
@@ -344,6 +344,124 @@
|
||||||
return found;
|
return found;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -220,10 +220,11 @@ index 5242c2a..e2e028a 100644
|
|||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
+#endif /* HAVE_SYSTEMD */
|
+#endif /* HAVE_SYSTEMD */
|
||||||
|
+
|
||||||
+
|
+
|
||||||
static const char *alloc_listener(process_rec *process, const char *addr,
|
static const char *alloc_listener(process_rec *process, const char *addr,
|
||||||
apr_port_t port, const char* proto,
|
apr_port_t port, const char* proto,
|
||||||
void *slave)
|
const char *scope_id, void *slave,
|
||||||
@@ -495,7 +621,7 @@ static int open_listeners(apr_pool_t *pool)
|
@@ -495,7 +621,7 @@ static int open_listeners(apr_pool_t *pool)
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
@ -285,7 +286,7 @@ index 5242c2a..e2e028a 100644
|
|||||||
|
|
||||||
rv = apr_parse_addr_port(&host, &scope_id, &port, argv[0], cmd->pool);
|
rv = apr_parse_addr_port(&host, &scope_id, &port, argv[0], cmd->pool);
|
||||||
if (rv != APR_SUCCESS) {
|
if (rv != APR_SUCCESS) {
|
||||||
@@ -856,6 +1007,12 @@ AP_DECLARE_NONSTD(const char *) ap_set_listener(cmd_parms *cmd, void *dummy,
|
@@ -928,6 +1046,12 @@
|
||||||
ap_str_tolower(proto);
|
ap_str_tolower(proto);
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -295,6 +296,6 @@ index 5242c2a..e2e028a 100644
|
|||||||
+ }
|
+ }
|
||||||
+#endif
|
+#endif
|
||||||
+
|
+
|
||||||
return alloc_listener(cmd->server->process, host, port, proto, NULL);
|
return alloc_listener(cmd->server->process, host, port, proto,
|
||||||
|
scope_id, NULL, cmd->temp_pool);
|
||||||
}
|
}
|
||||||
|
|
@ -40,7 +40,7 @@ ModularityLabel: %{name}:raven:%{version}:%{release}
|
|||||||
|
|
||||||
Summary: Apache HTTP Server
|
Summary: Apache HTTP Server
|
||||||
Name: httpd
|
Name: httpd
|
||||||
Version: 2.4.59
|
Version: 2.4.60
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: https://httpd.apache.org/
|
URL: https://httpd.apache.org/
|
||||||
Source0: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
Source0: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
||||||
@ -100,16 +100,15 @@ Patch21: httpd-2.4.48-r1842929+.patch
|
|||||||
Patch22: httpd-2.4.43-mod_systemd.patch
|
Patch22: httpd-2.4.43-mod_systemd.patch
|
||||||
Patch23: httpd-2.4.53-export.patch
|
Patch23: httpd-2.4.53-export.patch
|
||||||
Patch24: httpd-2.4.43-corelimit.patch
|
Patch24: httpd-2.4.43-corelimit.patch
|
||||||
Patch26: httpd-2.4.59-gettid.patch
|
|
||||||
Patch27: httpd-2.4.43-icons.patch
|
Patch27: httpd-2.4.43-icons.patch
|
||||||
Patch30: httpd-2.4.43-cachehardmax.patch
|
Patch30: httpd-2.4.43-cachehardmax.patch
|
||||||
Patch31: httpd-2.4.43-sslmultiproxy.patch
|
Patch31: httpd-2.4.43-sslmultiproxy.patch
|
||||||
Patch34: httpd-2.4.43-socket-activation.patch
|
Patch34: httpd-2.4.60-socket-activation.patch
|
||||||
Patch38: httpd-2.4.43-sslciphdefault.patch
|
Patch38: httpd-2.4.43-sslciphdefault.patch
|
||||||
Patch39: httpd-2.4.43-sslprotdefault.patch
|
Patch39: httpd-2.4.43-sslprotdefault.patch
|
||||||
Patch42: httpd-2.4.59-unifycgid.patch
|
#Patch42: httpd-2.4.59-unifycgid.patch
|
||||||
Patch45: httpd-2.4.43-logjournal.patch
|
Patch45: httpd-2.4.43-logjournal.patch
|
||||||
Patch46: httpd-2.4.54-separate-systemd-fns.patch
|
Patch46: httpd-2.4.60-separate-systemd-fns.patch
|
||||||
Patch49: httpd-2.4.54-selinux.patch
|
Patch49: httpd-2.4.54-selinux.patch
|
||||||
Patch50: httpd-2.4.58-r1912477+.patch
|
Patch50: httpd-2.4.58-r1912477+.patch
|
||||||
Patch51: httpd-2.4.58-r1914365.patch
|
Patch51: httpd-2.4.58-r1914365.patch
|
||||||
@ -313,17 +312,13 @@ top of libnghttp2 for httpd 2.4 servers.
|
|||||||
%patch22 -p1 -b .mod_systemd
|
%patch22 -p1 -b .mod_systemd
|
||||||
%patch23 -p1 -b .export
|
%patch23 -p1 -b .export
|
||||||
%patch24 -p1 -b .corelimit
|
%patch24 -p1 -b .corelimit
|
||||||
%if 0%{?rhel} >= 8
|
|
||||||
# too new for el7
|
|
||||||
%patch26 -p1 -b .gettid
|
|
||||||
%endif
|
|
||||||
%patch27 -p1 -b .icons
|
%patch27 -p1 -b .icons
|
||||||
%patch30 -p1 -b .cachehardmax
|
%patch30 -p1 -b .cachehardmax
|
||||||
# build will fail without --enable-systemd
|
# build will fail without --enable-systemd
|
||||||
%patch34 -p1 -b .socketactivation
|
%patch34 -p1 -b .socketactivation
|
||||||
%patch38 -p1 -b .sslciphdefault
|
%patch38 -p1 -b .sslciphdefault
|
||||||
%patch39 -p1 -b .sslprotdefault
|
%patch39 -p1 -b .sslprotdefault
|
||||||
%patch42 -p1 -b .unifycgid
|
#patch42 -p1 -b .unifycgid
|
||||||
%patch45 -p1 -b .logjournal
|
%patch45 -p1 -b .logjournal
|
||||||
%patch46 -p1 -b .separatesystemd
|
%patch46 -p1 -b .separatesystemd
|
||||||
%patch49 -p1 -b .selinux
|
%patch49 -p1 -b .selinux
|
||||||
@ -916,6 +911,9 @@ exit $rv
|
|||||||
%{_rpmconfigdir}/macros.d/macros.httpd
|
%{_rpmconfigdir}/macros.d/macros.httpd
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 1 2024 Raven <raven@sysadmins.ws> - 2.4.60-1
|
||||||
|
- update to 2.4.60
|
||||||
|
|
||||||
* Mon Apr 8 2024 Raven <raven@sysadmins.ws> - 2.4.59-1
|
* Mon Apr 8 2024 Raven <raven@sysadmins.ws> - 2.4.59-1
|
||||||
- update to 2.4.59
|
- update to 2.4.59
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user