21 lines
692 B
Diff
21 lines
692 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index f8459c5..90b0ffd 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -247,6 +247,7 @@ if (NOT CLAZY_BUILD_WITH_CLANG)
|
|
endif()
|
|
|
|
# rpath
|
|
+if(FALSE) # Disable rpath
|
|
set(CMAKE_SKIP_BUILD_RPATH FALSE)
|
|
set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
|
|
set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
|
|
@@ -255,6 +256,7 @@ if (NOT CLAZY_BUILD_WITH_CLANG)
|
|
if("${isSystemDir}" STREQUAL "-1")
|
|
set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
|
|
endif("${isSystemDir}" STREQUAL "-1")
|
|
+endif()
|
|
|
|
# Build clazy-standalone
|
|
add_executable(clazy-standalone ${CLAZY_STANDALONE_SRCS})
|