raven-rhel8/extras/KF5/misc/krita/krita-use-older-version-of-python3.patch
2024-10-24 16:46:54 +06:00

23 lines
937 B
Diff

--- a/CMakeLists.txt 2024-10-23 11:09:04.810701319 +0600
+++ b/CMakeLists.txt 2024-10-23 11:18:53.711861131 +0600
@@ -330,7 +330,7 @@
endif (NOT CAN_USE_PYTHON_LIBS)
endif (Python_FOUND)
else(WIN32)
- find_package(PythonLibrary 3.8)
+ find_package(PythonLibrary 3.6)
endif(WIN32)
########################
--- a/cmake/modules/FindPythonLibrary.cmake 2024-09-30 22:58:27.000000000 +0600
+++ b/cmake/modules/FindPythonLibrary.cmake 2024-10-23 11:44:52.078705638 +0600
@@ -36,7 +36,7 @@
# on APPLE we search python using Python_ROOT_DIR set by the toolchain file
find_package(Python 3.8 REQUIRED COMPONENTS Development Interpreter)
else()
- find_package(Python 3.8 REQUIRED COMPONENTS Interpreter OPTIONAL_COMPONENTS Development)
+ find_package(Python 3.6 REQUIRED COMPONENTS Interpreter OPTIONAL_COMPONENTS Development)
endif()
message(STATUS "FindPythonLibrary: ${Python_Interpreter_FOUND}")