raven-rhel8/extras/KF6/gear/marble/marble-revert-c363124.patch

18 lines
862 B
Diff

diff -Naur a/src/plugins/runner/osm/CMakeLists.txt b/src/plugins/runner/osm/CMakeLists.txt
--- a/src/plugins/runner/osm/CMakeLists.txt 2024-12-04 09:08:37.000000000 +0600
+++ b/src/plugins/runner/osm/CMakeLists.txt 2024-12-24 16:47:38.639011763 +0600
@@ -10,12 +10,11 @@
)
if(Protobuf_FOUND AND Protobuf_PROTOC_EXECUTABLE AND NOT MSVC) # FIXME linking issue on Windows
- find_package( absl REQUIRED)
protobuf_generate_cpp(pbf_srcs pbf_hdrs
${CMAKE_SOURCE_DIR}/tools/osm-addresses/pbf/fileformat.proto
${CMAKE_SOURCE_DIR}/tools/osm-addresses/pbf/osmformat.proto
)
- set(EXTRA_LIBS protobuf::libprotobuf protobuf::libprotoc ${ZLIB_LIBRARIES} absl::log_internal_message absl::log_internal_check_op)
+ set(EXTRA_LIBS protobuf::libprotobuf protobuf::libprotoc ${ZLIB_LIBRARIES})
add_definitions(-DHAVE_PROTOBUF)
if(MSVC)