kf6: update miscellanious software versions

This commit is contained in:
Raven 2024-08-23 14:48:50 +06:00
parent c5b823899e
commit a5c6bbeace
22 changed files with 2095 additions and 38 deletions

View File

@ -1,3 +1,4 @@
%bcond_with gcc
%bcond_with qt5
%undefine __cmake_in_source_build
@ -22,7 +23,11 @@ BuildRequires: cmake(Qt6Sql)
BuildRequires: cmake(Qt5DBus)
BuildRequires: cmake(Qt5Sql)
%endif
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
# required for /usr/share/dbus-1/interfaces/*.xml
BuildRequires: PackageKit >= 0.9.1
@ -67,6 +72,12 @@ Requires: PackageKit-Qt6%{?_isa} = %{version}-%{release}
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
mkdir -p pkqt6
pushd pkqt6
%cmake -S .. -DBUILD_WITH_QT6=ON

View File

@ -1,3 +1,5 @@
%bcond_with gcc
%global _rxlibdir /opt/rx/%{_lib}
%global _rxincludedir /opt/rx/include
@ -10,7 +12,11 @@ License: GPLv2
Summary: Library collection to easily create Wayland and X11 compositors
BuildRequires: cmake
BuildRequires: gcc
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: extra-cmake-modules >= 6.0
BuildRequires: libepoxy-devel
BuildRequires: pixman-devel
@ -59,6 +65,12 @@ Requires: %{name} = %{version}-%{release}
%autosetup -p1
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
export PKG_CONFIG_PATH=%{_rxlibdir}/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}
export LDFLAGS="-L%{_rxlibdir} -Wl,-rpath=%{_rxlibdir} ${LDFLAGS:-%__global_ldflags}"
%cmake_kf6
@ -105,4 +117,4 @@ done
%{_libdir}/cmake/KWinDBusInterface/*.cmake
%{_libdir}/cmake/como/*
%{_includedir}/como/*
%{_includedir}/como_version.h
%{_includedir}/como_version.h

View File

@ -0,0 +1,10 @@
[Desktop Entry]
Categories=Qt;KDE;Graphics;Photography;
Exec=digikam --download-from %f
GenericName=Photo Management Program
Icon=digikam
MimeType=x-content/image-dcf;x-content/image-picturecd;
Name=digiKam
NoDisplay=true
Terminal=false
Type=Application

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,181 @@
diff -Naur a/cmake/kColorPickerConfig.cmake.in b/cmake/kColorPickerConfig.cmake.in
--- a/cmake/kColorPickerConfig.cmake.in 2024-03-01 21:47:22.000000000 +0600
+++ b/cmake/kColorPickerConfig.cmake.in 1970-01-01 06:00:00.000000000 +0600
@@ -1,9 +0,0 @@
-include(CMakeFindDependencyMacro)
-
-@PACKAGE_INIT@
-
-find_dependency(Qt@QT_MAJOR_VERSION@ @QT_MIN_VERSION@ COMPONENTS Widgets)
-
-if(NOT TARGET kColorPicker::kColorPicker)
- include("${CMAKE_CURRENT_LIST_DIR}/kColorPicker-targets.cmake")
-endif()
diff -Naur a/cmake/kColorPicker-Qt5Config.cmake.in b/cmake/kColorPicker-Qt5Config.cmake.in
--- a/cmake/kColorPicker-Qt5Config.cmake.in 1970-01-01 06:00:00.000000000 +0600
+++ b/cmake/kColorPicker-Qt5Config.cmake.in 2024-08-08 11:01:51.973202565 +0600
@@ -0,0 +1,9 @@
+include(CMakeFindDependencyMacro)
+
+@PACKAGE_INIT@
+
+find_dependency(Qt5 @QT_MIN_VERSION@ COMPONENTS Widgets)
+
+if(NOT TARGET kColorPicker::kColorPicker-Qt5)
+ include("${CMAKE_CURRENT_LIST_DIR}/kColorPicker-Qt5-targets.cmake")
+endif()
diff -Naur a/cmake/kColorPicker-Qt6Config.cmake.in b/cmake/kColorPicker-Qt6Config.cmake.in
--- a/cmake/kColorPicker-Qt6Config.cmake.in 1970-01-01 06:00:00.000000000 +0600
+++ b/cmake/kColorPicker-Qt6Config.cmake.in 2024-08-08 11:01:51.973202565 +0600
@@ -0,0 +1,9 @@
+include(CMakeFindDependencyMacro)
+
+@PACKAGE_INIT@
+
+find_dependency(Qt6 @QT_MIN_VERSION@ COMPONENTS Widgets)
+
+if(NOT TARGET kColorPicker::kColorPicker-Qt6)
+ include("${CMAKE_CURRENT_LIST_DIR}/kColorPicker-Qt6-targets.cmake")
+endif()
diff -Naur a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2024-03-01 21:47:22.000000000 +0600
+++ b/CMakeLists.txt 2024-08-08 11:01:51.973202565 +0600
@@ -3,7 +3,7 @@
set(QT_MIN_VERSION 5.15.2)
-set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_CXX_STANDARD 11)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
@@ -15,9 +15,12 @@
option(BUILD_WITH_QT6 "Build with Qt6" OFF)
if(BUILD_WITH_QT6)
+ set(CMAKE_CXX_STANDARD 17)
set(QT_MAJOR_VERSION 6)
+ set(kColorPicker_LIB_NAME "kColorPicker-Qt6")
else()
set(QT_MAJOR_VERSION 5)
+ set(kColorPicker_LIB_NAME "kColorPicker-Qt5")
endif()
find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED Widgets)
@@ -41,24 +44,26 @@
include(CMakePackageConfigHelpers)
-add_library(kColorPicker
+add_library(${kColorPicker_LIB_NAME}
${KCOLORPICKER_SRCS}
${CMAKE_CURRENT_SOURCE_DIR}/include/kColorPicker/KColorPicker.h
${CMAKE_CURRENT_SOURCE_DIR}/icons/kColorPicker_icons.qrc
)
-target_include_directories(kColorPicker
+#add_library(kColorPicker::kColorPicker ALIAS kColorPicker)
+
+target_include_directories(${kColorPicker_LIB_NAME}
PUBLIC
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
$<BUILD_INTERFACE:${CMAKE_CURRENT_BINARY_DIR}/include>
- $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}/kColorPicker-Qt${QT_MAJOR_VERSION}>
+ $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>/${kColorPicker_LIB_NAME}
)
-target_link_libraries(kColorPicker PUBLIC Qt${QT_MAJOR_VERSION}::Widgets)
+target_link_libraries(${kColorPicker_LIB_NAME} PUBLIC Qt${QT_MAJOR_VERSION}::Widgets)
-target_compile_definitions(kColorPicker PRIVATE KIMAGEANNOTATOR_LIB)
+target_compile_definitions(${kColorPicker_LIB_NAME} PRIVATE KIMAGEANNOTATOR_LIB)
-set_target_properties(kColorPicker
+set_target_properties(${kColorPicker_LIB_NAME}
PROPERTIES
ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/lib
LIBRARY_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/lib
@@ -67,43 +72,43 @@
SOVERSION 0
)
-install(TARGETS kColorPicker
- EXPORT kColorPicker-targets
+install(TARGETS ${kColorPicker_LIB_NAME}
+ EXPORT ${kColorPicker_LIB_NAME}-targets
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
)
install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/include/kColorPicker
- DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/kColorPicker-Qt${QT_MAJOR_VERSION}
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/${kColorPicker_LIB_NAME}
)
-configure_package_config_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/kColorPickerConfig.cmake.in
- ${CMAKE_CURRENT_BINARY_DIR}/cmake/kColorPicker-Qt${QT_MAJOR_VERSION}Config.cmake
- INSTALL_DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/kColorPicker-Qt${QT_MAJOR_VERSION}
+configure_package_config_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/${kColorPicker_LIB_NAME}Config.cmake.in
+ ${CMAKE_CURRENT_BINARY_DIR}/cmake/${kColorPicker_LIB_NAME}Config.cmake
+ INSTALL_DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${kColorPicker_LIB_NAME}
)
-write_basic_package_version_file(${CMAKE_CURRENT_BINARY_DIR}/cmake/kColorPicker-Qt${QT_MAJOR_VERSION}Config-version.cmake
+write_basic_package_version_file(${CMAKE_CURRENT_BINARY_DIR}/cmake/${kColorPicker_LIB_NAME}Config-version.cmake
VERSION ${PROJECT_VERSION}
COMPATIBILITY AnyNewerVersion
)
install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/cmake/kColorPicker-Qt${QT_MAJOR_VERSION}Config.cmake
- ${CMAKE_CURRENT_BINARY_DIR}/cmake/kColorPicker-Qt${QT_MAJOR_VERSION}Config-version.cmake
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/kColorPicker-Qt${QT_MAJOR_VERSION}
+ ${CMAKE_CURRENT_BINARY_DIR}/cmake/${kColorPicker_LIB_NAME}Config.cmake
+ ${CMAKE_CURRENT_BINARY_DIR}/cmake/${kColorPicker_LIB_NAME}Config-version.cmake
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${kColorPicker_LIB_NAME}
)
-export(EXPORT kColorPicker-targets
- FILE ${CMAKE_CURRENT_BINARY_DIR}/cmake/kColorPicker-Qt${QT_MAJOR_VERSION}-targets.cmake
+export(EXPORT ${kColorPicker_LIB_NAME}-targets
+ FILE ${CMAKE_CURRENT_BINARY_DIR}/cmake/${kColorPicker_LIB_NAME}-targets.cmake
NAMESPACE kColorPicker::
)
-install(EXPORT kColorPicker-targets
- FILE kColorPicker-targets.cmake
+install(EXPORT ${kColorPicker_LIB_NAME}-targets
+ FILE ${kColorPicker_LIB_NAME}-targets.cmake
NAMESPACE kColorPicker::
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/kColorPicker-Qt${QT_MAJOR_VERSION}
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${kColorPicker_LIB_NAME}
)
# uninstall target
diff -Naur a/example/CMakeLists.txt b/example/CMakeLists.txt
--- a/example/CMakeLists.txt 2024-03-01 21:47:22.000000000 +0600
+++ b/example/CMakeLists.txt 2024-08-08 11:01:51.973202565 +0600
@@ -1,3 +1,3 @@
add_executable(kColorPicker-example main.cpp)
-target_link_libraries(kColorPicker-example kColorPicker)
+target_link_libraries(kColorPicker-example ${kColorPicker_LIB_NAME})
diff -Naur a/README.md b/README.md
--- a/README.md 2024-03-01 21:47:22.000000000 +0600
+++ b/README.md 2024-08-08 11:01:51.973202565 +0600
@@ -36,8 +36,11 @@
to build with Qt6:
`find_package(kColorPicker-Qt6 ${KCOLORPICKER_MIN_VERSION} REQUIRED)`
-2. Link the library with your application
- `target_link_libraries(myApp kColorPicker)`
+2. Link the library with your application
+ if you built with Qt5:
+ `target_link_libraries(myApp kColorPicker-Qt5)`
+ if you built with Qt6:
+ `target_link_libraries(myApp kColorPicker-Qt6)`
[github-badge]: https://github.com/ksnip/kColorPicker/actions/workflows/build.yml/badge.svg

View File

@ -1,15 +1,19 @@
%bcond_with gcc
%global appname kColorPicker
%global libname lib%{appname}
Name: kcolorpicker
Version: 0.3.0
Release: 2%{?dist}
Version: 0.3.1
Release: 1%{?dist}
License: LGPL-3.0-or-later
Summary: QToolButton control with color popup menu
URL: https://github.com/ksnip/%{appname}
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch0: kcolorpicker-revert-f58d6ad.patch
BuildRequires: cmake(Qt5Core)
BuildRequires: cmake(Qt5Gui)
@ -17,9 +21,16 @@ BuildRequires: cmake(Qt6Core)
BuildRequires: cmake(Qt6Gui)
BuildRequires: cmake
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: ninja-build
Provides: %{name}-qt6 = %{?epoch:%{epoch}:}%{version}-%{release}
Obsoletes: %{name}-qt6 < %{version}
%description
QToolButton with color popup menu which lets you select a color.
@ -29,26 +40,37 @@ custom colors to the popup menu.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
Provides: %{name}-qt6-devel = %{?epoch:%{epoch}:}%{version}-%{release}
Obsoletes: %{name}-qt6-devel < %{version}
%description devel
%{summary}.
%package qt6
Summary: QToolButton control with color popup menu (Qt6)
%description qt6
%package qt5
Summary: QToolButton control with color popup menu (Qt5)
Obsoletes: %{name} < %{version}
%description qt5
%{summary}.
%package qt6-devel
Summary: Qt6 Development files for %{name}
Requires: %{name}-qt6%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
%package qt5-devel
Summary: Qt5 Development files for %{name}
Requires: %{name}-qt5%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
Obsoletes: %{name}-devel < %{version}
%description qt6-devel
%description qt5-devel
%{summary}.
%prep
%autosetup -n %{appname}-%{version} -p1
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
mkdir qt5
pushd qt5
%cmake -G Ninja \
@ -80,24 +102,29 @@ popd
%files
%doc README.md
%license LICENSE
%{_libdir}/%{libname}-Qt5.so.0*
%files devel
%{_includedir}/%{appname}-Qt5/
%{_libdir}/cmake/%{appname}-Qt5/
%{_libdir}/%{libname}-Qt5.so
%files qt6
%doc README.md
%license LICENSE
%{_libdir}/%{libname}-Qt6.so.0*
%files qt6-devel
%files devel
%{_includedir}/%{appname}-Qt6/
%{_libdir}/cmake/%{appname}-Qt6/
%{_libdir}/%{libname}-Qt6.so
%files qt5
%doc README.md
%license LICENSE
%{_libdir}/%{libname}-Qt5.so.0*
%files qt5-devel
%{_includedir}/%{appname}-Qt5/
%{_libdir}/cmake/%{appname}-Qt5/
%{_libdir}/%{libname}-Qt5.so
%changelog
* Thu Aug 8 2024 Raven <raven@sysadmins.ws> - 0.3.1-1
- update to 0.3.1
- add patch to use different names for Qt5 and Qt6 files
- swap -qt6 and -qt5 packages
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

View File

@ -1,3 +1,5 @@
%bcond_with gcc
Name: kdiagram
Summary: Powerful libraries (KChart, KGantt) for creating business diagrams
Version: 3.0.1
@ -40,6 +42,12 @@ Developer Documentation files for %{name} for use with KDevelop or QtCreator.
%autosetup -p1 -n %{name}-%{version}
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
%cmake_kf6
%cmake_build

View File

@ -1,3 +1,5 @@
%bcond_with gcc
%undefine __cmake_in_source_build
# %%global gitcommit_full ad0d6a26ef59652247322971753bf142231a703a
# %%global gitcommit %%(c=%%{gitcommit_full}; echo ${c:0:7})
@ -12,7 +14,11 @@ URL: https://github.com/KDE/kdiff3
Source0: https://invent.kde.org/sdk/kdiff3/-/archive/%{version}/%{name}-%{version}.tar.xz
BuildRequires: cmake3
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: desktop-file-utils
BuildRequires: gettext
BuildRequires: libappstream-glib
@ -51,6 +57,12 @@ KDiff3 is a program that
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
%cmake_kf6 -DBUILD_WITH_QT6:BOOL=ON
%cmake_build

View File

@ -0,0 +1,137 @@
%bcond_with gcc
%global framework kirigami-addons
Name: kf6-%{framework}
Version: 1.4.0
Release: 1%{?dist}
License: BSD-2-Clause AND CC-BY-SA-4.0 AND CC0-1.0 AND GPL-2.0-only AND GPL-2.0-or-later AND GPL-3.0-only AND LGPL-2.0-only AND LGPL-2.0-or-later AND LGPL-2.1-only AND LGPL-2.1-or-later AND LGPL-3.0-only AND (GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only) AND LicenseRef-KFQF-Accepted-GPL
Summary: Convergent visual components ("widgets") for Kirigami-based applications
Url: https://invent.kde.org/libraries/%{framework}
Source: https://download.kde.org/stable/%{framework}/%{framework}-%{version}.tar.xz
BuildRequires: cmake
BuildRequires: extra-cmake-modules
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: kf6-rpm-macros
BuildRequires: cmake(KF6I18n)
BuildRequires: cmake(KF6Kirigami2)
BuildRequires: cmake(KF6Svg)
BuildRequires: qt6-qtbase-private-devel
BuildRequires: cmake(Qt6)
BuildRequires: cmake(Qt6Core)
BuildRequires: cmake(Qt6Quick)
BuildRequires: cmake(Qt6QuickControls2)
Requires: kf6-filesystem
### Renamed from kf6-kirigami2-addons (which was at epoch 1)
Obsoletes: kf6-kirigami2-addons < 1:0.11.76-5
Provides: kf6-kirigami2-addons = 1:%{version}-%{release}
Provides: kf6-kirigami2-addons%{?_isa} = 1:%{version}-%{release}
### Merged subpackages back into main package
# The old name
Obsoletes: kf6-kirigami2-addons-dateandtime < 1:0.11.76-5
Provides: kf6-kirigami2-addons-dateandtime = 1:%{version}-%{release}
Provides: kf6-kirigami2-addons-dateandtime%{?_isa} = 1:%{version}-%{release}
Obsoletes: kf6-kirigami2-addons-treeview < 1:0.11.76-5
Provides: kf6-kirigami2-addons-treeview = 1:%{version}-%{release}
Provides: kf6-kirigami2-addons-treeview%{?_isa} = 1:%{version}-%{release}
# The new name
Obsoletes: kf6-kirigami-addons-dateandtime < 0.11.76-5
Provides: kf6-kirigami-addons-dateandtime = %{version}-%{release}
Provides: kf6-kirigami-addons-dateandtime%{?_isa} = %{version}-%{release}
Obsoletes: kf6-kirigami-addons-treeview < 0.11.76-5
Provides: kf6-kirigami-addons-treeview = %{version}-%{release}
Provides: kf6-kirigami-addons-treeview%{?_isa} = %{version}-%{release}
%description
A set of "widgets" i.e visual end user components along with a
code to support them. Components are usable by both touch and
desktop experiences providing a native experience on both, and
look native with any QQC2 style (qqc2-desktop-theme, Material
or Plasma).
%package devel
Summary: Development files for %{name}
Requires: %{name} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%autosetup -n %{framework}-%{version}
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
%cmake_kf6 -DBUILD_WITH_QT6=ON
%cmake_build
%install
%cmake_install
%find_lang %{orig_name}6 --all-name
%files -f %{orig_name}6.lang
%doc README.md
%license LICENSES/
%{_kf6_libdir}/libKirigamiAddonsStatefulApp.so.*
%dir %{_kf6_qmldir}/org/kde
%{_kf6_qmldir}/org/kde/kirigamiaddons
%{_kf6_datadir}/kdevappwizard/templates/kirigamiaddons6.tar.bz2
%files devel
%{_kf6_libdir}/cmake/KF6KirigamiAddons
%{_kf6_libdir}/libKirigamiAddonsStatefulApp.so
%{_includedir}/KirigamiAddonsStatefulApp/*
%changelog
* Wed Aug 7 2024 Raven <raven@sysadmins.ws> - 1.4.0-1
- 1.4.0
- move headers and cmake files to separate devel package
* Fri Jun 28 2024 Raven <raven@sysadmins.ws> - 1.3.0-1
- 1.3.0
* Tue Jun 11 2024 Raven <raven@sysadmins.ws> - 1.2.1-1
- 1.2.1
* Thu Feb 22 2024 Alessandro Astone <ales.astone@gmail.com> - 1.0.0-1
- 1.0.0
* Fri Feb 16 2024 Jan Grulich <jgrulich@redhat.com> - 0.11.90-4
- Rebuild (qt6)
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.90-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.90-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Wed Jan 10 2024 Alessandro Astone <ales.astone@gmail.com> - 0.11.90-1
- 0.11.90
* Wed Jan 10 2024 Alessandro Astone <ales.astone@gmail.com> - 0.11.76-3
- Remove subpackages
* Sun Dec 03 2023 Alessandro Astone <ales.astone@gmail.com> - 0.11.76-2
- Add arch-ed provides
* Thu Nov 30 2023 Alessandro Astone <ales.astone@gmail.com> - 0.11.76-1
- Renamed from kf6-kirigami2-addons

View File

@ -1,3 +1,5 @@
%bcond_with gcc
Name: kgraphviewer
Summary: Graphviz dot graph file viewer
Version: 2.5.0
@ -66,6 +68,12 @@ th KGraphViewer library.
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
%cmake_kf6
%cmake_build

View File

@ -1,3 +1,5 @@
%bcond_with gcc
%if 0%{?fedora} >= 40 || 0%{?rhel} >= 8
%bcond_without kf6
%endif
@ -110,6 +112,12 @@ built without KDE dependencies.
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
# lib64 stuff: //bugzilla.redhat.com/show_bug.cgi?id=1425064
%if %{with kf6}
%cmake_kf6 \

View File

@ -1,3 +1,5 @@
%bcond_with gcc
%global appname kImageAnnotator
%global libname lib%{appname}
@ -25,7 +27,11 @@ BuildRequires: cmake(Qt6Svg)
BuildRequires: cmake
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: ninja-build
Requires: %{name}-common%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
@ -63,6 +69,12 @@ Summary: Common language translations for Qt5 and Qt6 builds
%autosetup -n %{appname}-%{version} -p1
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
mkdir qt5
pushd qt5
%cmake -G Ninja \

View File

@ -1,3 +1,5 @@
%bcond_with gcc
Name: kommit
Version: 1.6.0
Release: 1%{?dist}
@ -7,7 +9,11 @@ License: GPL-3.0-or-later AND GPL-2.0-or-later AND BSD-3-Clause
URL: https://apps.kde.org/kommit/
Source0: https://download.kde.org/stable/kommit/%{name}-%{version}.tar.xz
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: cmake
BuildRequires: extra-cmake-modules
BuildRequires: desktop-file-utils
@ -45,6 +51,12 @@ Obsoletes: gitklient < 1.0
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
%cmake_kf6 -DQT_MAJOR_VERSION=6
%cmake_build

View File

@ -1,3 +1,5 @@
%bcond_with gcc
Name: ktextaddons
Version: 1.5.4
Release: 1%{?dist}
@ -10,7 +12,11 @@ URL: https://invent.kde.org/libraries/%{name}
Source0: http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
BuildRequires: cmake
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: kf5-rpm-macros
BuildRequires: kf6-rpm-macros
BuildRequires: extra-cmake-modules
@ -90,6 +96,12 @@ BuildArch: noarch
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
mkdir %{name}_qt5
mkdir %{name}_qt6
pushd %{name}_qt6

View File

@ -1,13 +1,19 @@
%bcond_with gcc
Name: mpvqt
Version: 1.0.0
Release: 3%{?dist}
Version: 1.0.1
Release: 1%{?dist}
Summary: QML wrapper for libmpv
License: LGPL-2.1-only OR LGPL-3.0-only
URL: https://invent.kde.org/libraries/mpvqt
Source: https://download.kde.org/stable/mpvqt/mpvqt-%{version}.tar.xz
BuildRequires: extra-cmake-modules
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: kf6-rpm-macros
BuildRequires: cmake(Qt6Quick)
BuildRequires: pkgconfig(mpv)
@ -29,6 +35,12 @@ Development headers and link library for building packages which use %{name}.
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
%cmake_kf6
%cmake_build
@ -49,6 +61,9 @@ Development headers and link library for building packages which use %{name}.
%changelog
* Wed Aug 7 2024 Raven <raven@sysadmins.ws> - 1.0.1-1
- 1.0.1
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

View File

@ -1,3 +1,5 @@
%bcond_with gcc
Summary: Multimedia framework api
Name: phonon
Version: 4.12.0
@ -8,7 +10,11 @@ URL: https://community.kde.org/Phonon
Source0: https://download.kde.org/stable/phonon/%{version}/phonon-%{version}.tar.xz
BuildRequires: cmake
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: extra-cmake-modules
BuildRequires: kf6-rpm-macros
BuildRequires: kf5-rpm-macros > 5.96
@ -66,6 +72,12 @@ BuildArch: noarch
%autosetup -n phonon-%{version} -p1
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
mkdir -p phononqt6
pushd phononqt6
%cmake_kf6 -S .. \

View File

@ -1,12 +1,19 @@
%bcond_with gcc
Name: pulseaudio-qt
Summary: Qt bindings for PulseAudio
Version: 1.5.0
Release: 1%{?dist}
Release: 2%{?dist}
License: CC0-1.0 AND LGPL-2.1-only AND LGPL-3.0-only
URL: https://invent.kde.org/libraries/pulseaudio-qt
Source: https://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++ gcc-toolset-14-gcc-plugin-annobin
%else
BuildRequires: clang
%endif
BuildRequires: extra-cmake-modules
BuildRequires: kf6-rpm-macros
BuildRequires: kf5-rpm-macros
@ -60,6 +67,12 @@ Developer Documentation files for %{name} for use with KDevelop or QtCreator.
%autosetup
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
mkdir %{name}_qt5
pushd %{name}_qt5
%cmake_kf5 -DQT_MAJOR_VERSION=5 -S../
@ -110,6 +123,9 @@ rm %{buildroot}%{_kf5_includedir}/pulseaudioqt_version.h
%{_qt6_docdir}/*.qch
%changelog
* Tue Aug 13 2024 Raven <raven@sysadmins.ws> - 1.5.0-2
- build with gcc-toolset-14
* Fri May 24 2024 Marc Deop i Argemí <marcdeop@fedoraproject.org> - 1.5.0-1
- 1.5.0

View File

@ -1,3 +1,5 @@
%bcond_with gcc
Name: qaccessibilityclient
Summary: Accessibility client library for Qt6
Version: 0.5.0
@ -10,7 +12,11 @@ Source0: https://download.kde.org/stable/libqaccessibilityclient/libqaccessibili
## upstream patches
BuildRequires: cmake
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: cmake(Qt6)
BuildRequires: cmake(Qt6DBus)
BuildRequires: cmake(Qt6Widgets)
@ -36,6 +42,12 @@ Requires: qt6-qtbase-devel
%autosetup -n libqaccessibilityclient-%{version} -p1
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
%cmake_kf6 -DQT_MAJOR_VERSION=6
%cmake_build

View File

@ -2,12 +2,15 @@
%global botan 1
%endif
%bcond_with gcc
%bcond_without qt5
%bcond_without qt6
#global doc 1
%global tests 1
%undefine __cmake_in_source_build
Name: qca
Summary: Qt Cryptographic Architecture
Version: 2.3.9
@ -24,7 +27,11 @@ Patch1: fix-build-with-old-gcrypt.patch
## upstreamable patches
BuildRequires: cmake >= 2.8.12
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: libgcrypt-devel
BuildRequires: pkgconfig(libcrypto) pkgconfig(libssl)
BuildRequires: pkgconfig(nss)
@ -225,6 +232,12 @@ Requires: %{name}-qt6%{?_isa} = %{version}-%{release}
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
cmake_opts="-Wno-dev \
-DBUILD_TESTS:BOOL=%{?tests:ON}%{!?tests:OFF} \
-DQCA_INSTALL_IN_QT_PREFIX:BOOL=ON \

View File

@ -1,3 +1,4 @@
%bcond_with gcc
# Disable X11 for RHEL 10+
%bcond_without x11
@ -164,6 +165,12 @@ ls -sh src/greeter/theme/background.png
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
%cmake \
-DBUILD_WITH_QT6:BOOL=ON \
-DBUILD_MAN_PAGES:BOOL=ON \

View File

@ -1,3 +1,4 @@
%bcond_with gcc
%global gitdate 20240205
%global commit0 c8ad98249af541514ff7a81634d3295e712f1a39
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
@ -21,10 +22,14 @@ Source0: https://gitlab.com/nicolasfella/signond/-/archive/%{commit0}/sig
#Source0: https://gitlab.com/accounts-sso/signond/repository/archive.tar.gz?ref=%%{commit0}#/%%{name}-%%{shortcommit0}.tar.gz
#%%endif
BuildRequires: make
BuildRequires: make
BuildRequires: dbus-x11
BuildRequires: doxygen
BuildRequires: gcc-c++
%if %{with gcc}
BuildRequires: gcc-toolset-14-gcc-c++
%else
BuildRequires: clang
%endif
BuildRequires: graphviz
BuildRequires: libproxy-devel
BuildRequires: qt5-qtbase-devel
@ -92,6 +97,12 @@ The %{name}-doc package contains documentation for %{name}.
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
mkdir %{name}_qt5
pushd %{name}_qt5
%qmake_qt5 \

View File

@ -1,3 +1,5 @@
%bcond_with gcc
Name: theseus-ship
Version: 6.0.0
Release: 1%{dist}
@ -46,6 +48,12 @@ KWin in that it uses The Compositor Modules.
%autosetup -p1
%build
%if %{with gcc}
%enable_devtoolset14
export CC=gcc
export CXX=c++
%endif
%cmake_kf6
%cmake_build
@ -65,4 +73,4 @@ KWin in that it uses The Compositor Modules.
%{_datadir}/applications/kcm_kwin*.desktop
%{_datadir}/applications/kwincompositing.desktop
%{_datadir}/config.kcfg/*.kcfg
%{_datadir}/knsrcfiles/*.knsrc
%{_datadir}/knsrcfiles/*.knsrc