eigen3: 3.4.0
This commit is contained in:
parent
9216ebaeeb
commit
840fefa599
58
extras/eigen3/0001-fix_zvector_build.patch
Normal file
58
extras/eigen3/0001-fix_zvector_build.patch
Normal file
@ -0,0 +1,58 @@
|
||||
From 18824d10eaa46b39d42ae2b437fe760a2be25a7b Mon Sep 17 00:00:00 2001
|
||||
From: Antonio Sanchez <cantonios@google.com>
|
||||
Date: Fri, 22 Oct 2021 08:52:16 -0700
|
||||
Subject: [PATCH] Fix ZVector build.
|
||||
|
||||
Cross-compiled via `s390x-linux-gnu-g++`, run via qemu. This allows the
|
||||
packetmath tests to pass.
|
||||
|
||||
|
||||
(cherry picked from commit 40bbe8a4d0eb3ec2bfd472fa30cac19e6e743b46)
|
||||
---
|
||||
Eigen/src/Core/arch/ZVector/Complex.h | 14 ++++++++++++--
|
||||
Eigen/src/Core/arch/ZVector/PacketMath.h | 4 ++--
|
||||
2 files changed, 14 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Eigen/src/Core/arch/ZVector/Complex.h b/Eigen/src/Core/arch/ZVector/Complex.h
|
||||
index 0b9b33d99d..e0acedefbd 100644
|
||||
--- a/Eigen/src/Core/arch/ZVector/Complex.h
|
||||
+++ b/Eigen/src/Core/arch/ZVector/Complex.h
|
||||
@@ -91,8 +91,18 @@ template<> struct packet_traits<std::complex<double> > : default_packet_traits
|
||||
};
|
||||
};
|
||||
|
||||
-template<> struct unpacket_traits<Packet2cf> { typedef std::complex<float> type; enum {size=2, alignment=Aligned16, vectorizable=true, masked_load_available=false, masked_store_available=false}; typedef Packet2cf half; };
|
||||
-template<> struct unpacket_traits<Packet1cd> { typedef std::complex<double> type; enum {size=1, alignment=Aligned16, vectorizable=true, masked_load_available=false, masked_store_available=false}; typedef Packet1cd half; };
|
||||
+template<> struct unpacket_traits<Packet2cf> {
|
||||
+ typedef std::complex<float> type;
|
||||
+ enum {size=2, alignment=Aligned16, vectorizable=true, masked_load_available=false, masked_store_available=false};
|
||||
+ typedef Packet2cf half;
|
||||
+ typedef Packet4f as_real;
|
||||
+};
|
||||
+template<> struct unpacket_traits<Packet1cd> {
|
||||
+ typedef std::complex<double> type;
|
||||
+ enum {size=1, alignment=Aligned16, vectorizable=true, masked_load_available=false, masked_store_available=false};
|
||||
+ typedef Packet1cd half;
|
||||
+ typedef Packet2d as_real;
|
||||
+};
|
||||
|
||||
/* Forward declaration */
|
||||
EIGEN_STRONG_INLINE void ptranspose(PacketBlock<Packet2cf,2>& kernel);
|
||||
diff --git a/Eigen/src/Core/arch/ZVector/PacketMath.h b/Eigen/src/Core/arch/ZVector/PacketMath.h
|
||||
index 1f55a90a5c..208e4b167c 100755
|
||||
--- a/Eigen/src/Core/arch/ZVector/PacketMath.h
|
||||
+++ b/Eigen/src/Core/arch/ZVector/PacketMath.h
|
||||
@@ -91,8 +91,8 @@ static _EIGEN_DECLARE_CONST_FAST_Packet2l(ZERO, 0);
|
||||
static _EIGEN_DECLARE_CONST_FAST_Packet2l(ONE, 1);
|
||||
|
||||
static Packet2d p2d_ONE = { 1.0, 1.0 };
|
||||
-static Packet2d p2d_ZERO_ = { numext::bit_cast<double>0x8000000000000000ull),
|
||||
- numext::bit_cast<double>0x8000000000000000ull) };
|
||||
+static Packet2d p2d_ZERO_ = { numext::bit_cast<double>(0x8000000000000000ull),
|
||||
+ numext::bit_cast<double>(0x8000000000000000ull) };
|
||||
|
||||
#if !defined(__ARCH__) || (defined(__ARCH__) && __ARCH__ >= 12)
|
||||
#define _EIGEN_DECLARE_CONST_FAST_Packet4f(NAME,X) \
|
||||
--
|
||||
GitLab
|
||||
|
@ -0,0 +1,167 @@
|
||||
From 23469c3cdaeeeb7b9f31e2d0971cddd114f1587d Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Krebbel <krebbel@linux.ibm.com>
|
||||
Date: Tue, 26 Oct 2021 15:29:30 +0200
|
||||
Subject: [PATCH] ZVector: Move alignas qualifier to come first
|
||||
|
||||
We currently have plenty of type definitions with the alignment
|
||||
qualifier coming after the type. The compiler warns about ignoring
|
||||
them:
|
||||
int EIGEN_ALIGN16 ai[4];
|
||||
|
||||
Turn this into:
|
||||
EIGEN_ALIGN16 int ai[4];
|
||||
|
||||
|
||||
(cherry picked from commit 8faafc3aaa2b45e234cfe0bef085c1134ceffc42)
|
||||
---
|
||||
Eigen/src/Core/arch/ZVector/Complex.h | 8 ++++----
|
||||
Eigen/src/Core/arch/ZVector/PacketMath.h | 24 ++++++++++++------------
|
||||
2 files changed, 16 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/Eigen/src/Core/arch/ZVector/Complex.h b/Eigen/src/Core/arch/ZVector/Complex.h
|
||||
index e0acedefbd..6c67cfe058 100644
|
||||
--- a/Eigen/src/Core/arch/ZVector/Complex.h
|
||||
+++ b/Eigen/src/Core/arch/ZVector/Complex.h
|
||||
@@ -160,7 +160,7 @@ template<> EIGEN_STRONG_INLINE void prefetch<std::complex<double> >(const std::c
|
||||
|
||||
template<> EIGEN_STRONG_INLINE std::complex<double> pfirst<Packet1cd>(const Packet1cd& a)
|
||||
{
|
||||
- std::complex<double> EIGEN_ALIGN16 res;
|
||||
+ EIGEN_ALIGN16 std::complex<double> res;
|
||||
pstore<std::complex<double> >(&res, a);
|
||||
|
||||
return res;
|
||||
@@ -205,7 +205,7 @@ template<> EIGEN_STRONG_INLINE void pstoreu<std::complex<float> >(std::complex<f
|
||||
|
||||
template<> EIGEN_STRONG_INLINE std::complex<float> pfirst<Packet2cf>(const Packet2cf& a)
|
||||
{
|
||||
- std::complex<float> EIGEN_ALIGN16 res[2];
|
||||
+ EIGEN_ALIGN16 std::complex<float> res[2];
|
||||
pstore<std::complex<float> >(res, a);
|
||||
|
||||
return res[0];
|
||||
@@ -235,14 +235,14 @@ template<> EIGEN_STRONG_INLINE Packet2cf pset1<Packet2cf>(const std::complex<flo
|
||||
|
||||
template<> EIGEN_DEVICE_FUNC inline Packet2cf pgather<std::complex<float>, Packet2cf>(const std::complex<float>* from, Index stride)
|
||||
{
|
||||
- std::complex<float> EIGEN_ALIGN16 af[2];
|
||||
+ EIGEN_ALIGN16 std::complex<float> af[2];
|
||||
af[0] = from[0*stride];
|
||||
af[1] = from[1*stride];
|
||||
return pload<Packet2cf>(af);
|
||||
}
|
||||
template<> EIGEN_DEVICE_FUNC inline void pscatter<std::complex<float>, Packet2cf>(std::complex<float>* to, const Packet2cf& from, Index stride)
|
||||
{
|
||||
- std::complex<float> EIGEN_ALIGN16 af[2];
|
||||
+ EIGEN_ALIGN16 std::complex<float> af[2];
|
||||
pstore<std::complex<float> >((std::complex<float> *) af, from);
|
||||
to[0*stride] = af[0];
|
||||
to[1*stride] = af[1];
|
||||
diff --git a/Eigen/src/Core/arch/ZVector/PacketMath.h b/Eigen/src/Core/arch/ZVector/PacketMath.h
|
||||
index 208e4b167c..a7b59c80ed 100755
|
||||
--- a/Eigen/src/Core/arch/ZVector/PacketMath.h
|
||||
+++ b/Eigen/src/Core/arch/ZVector/PacketMath.h
|
||||
@@ -358,7 +358,7 @@ pbroadcast4<Packet2d>(const double *a,
|
||||
|
||||
template<> EIGEN_DEVICE_FUNC inline Packet4i pgather<int, Packet4i>(const int* from, Index stride)
|
||||
{
|
||||
- int EIGEN_ALIGN16 ai[4];
|
||||
+ EIGEN_ALIGN16 int ai[4];
|
||||
ai[0] = from[0*stride];
|
||||
ai[1] = from[1*stride];
|
||||
ai[2] = from[2*stride];
|
||||
@@ -368,7 +368,7 @@ template<> EIGEN_DEVICE_FUNC inline Packet4i pgather<int, Packet4i>(const int* f
|
||||
|
||||
template<> EIGEN_DEVICE_FUNC inline Packet2d pgather<double, Packet2d>(const double* from, Index stride)
|
||||
{
|
||||
- double EIGEN_ALIGN16 af[2];
|
||||
+ EIGEN_ALIGN16 double af[2];
|
||||
af[0] = from[0*stride];
|
||||
af[1] = from[1*stride];
|
||||
return pload<Packet2d>(af);
|
||||
@@ -376,7 +376,7 @@ template<> EIGEN_DEVICE_FUNC inline Packet2d pgather<double, Packet2d>(const dou
|
||||
|
||||
template<> EIGEN_DEVICE_FUNC inline void pscatter<int, Packet4i>(int* to, const Packet4i& from, Index stride)
|
||||
{
|
||||
- int EIGEN_ALIGN16 ai[4];
|
||||
+ EIGEN_ALIGN16 int ai[4];
|
||||
pstore<int>((int *)ai, from);
|
||||
to[0*stride] = ai[0];
|
||||
to[1*stride] = ai[1];
|
||||
@@ -386,7 +386,7 @@ template<> EIGEN_DEVICE_FUNC inline void pscatter<int, Packet4i>(int* to, const
|
||||
|
||||
template<> EIGEN_DEVICE_FUNC inline void pscatter<double, Packet2d>(double* to, const Packet2d& from, Index stride)
|
||||
{
|
||||
- double EIGEN_ALIGN16 af[2];
|
||||
+ EIGEN_ALIGN16 double af[2];
|
||||
pstore<double>(af, from);
|
||||
to[0*stride] = af[0];
|
||||
to[1*stride] = af[1];
|
||||
@@ -460,8 +460,8 @@ template<> EIGEN_STRONG_INLINE void pstoreu<double>(double* to, const Packet2d&
|
||||
template<> EIGEN_STRONG_INLINE void prefetch<int>(const int* addr) { EIGEN_ZVECTOR_PREFETCH(addr); }
|
||||
template<> EIGEN_STRONG_INLINE void prefetch<double>(const double* addr) { EIGEN_ZVECTOR_PREFETCH(addr); }
|
||||
|
||||
-template<> EIGEN_STRONG_INLINE int pfirst<Packet4i>(const Packet4i& a) { int EIGEN_ALIGN16 x[4]; pstore(x, a); return x[0]; }
|
||||
-template<> EIGEN_STRONG_INLINE double pfirst<Packet2d>(const Packet2d& a) { double EIGEN_ALIGN16 x[2]; pstore(x, a); return x[0]; }
|
||||
+template<> EIGEN_STRONG_INLINE int pfirst<Packet4i>(const Packet4i& a) { EIGEN_ALIGN16 int x[4]; pstore(x, a); return x[0]; }
|
||||
+template<> EIGEN_STRONG_INLINE double pfirst<Packet2d>(const Packet2d& a) { EIGEN_ALIGN16 double x[2]; pstore(x, a); return x[0]; }
|
||||
|
||||
template<> EIGEN_STRONG_INLINE Packet4i preverse(const Packet4i& a)
|
||||
{
|
||||
@@ -639,7 +639,7 @@ pbroadcast4<Packet4f>(const float *a,
|
||||
|
||||
template<> EIGEN_DEVICE_FUNC inline Packet4f pgather<float, Packet4f>(const float* from, Index stride)
|
||||
{
|
||||
- float EIGEN_ALIGN16 ai[4];
|
||||
+ EIGEN_ALIGN16 float ai[4];
|
||||
ai[0] = from[0*stride];
|
||||
ai[1] = from[1*stride];
|
||||
ai[2] = from[2*stride];
|
||||
@@ -649,7 +649,7 @@ template<> EIGEN_DEVICE_FUNC inline Packet4f pgather<float, Packet4f>(const floa
|
||||
|
||||
template<> EIGEN_DEVICE_FUNC inline void pscatter<float, Packet4f>(float* to, const Packet4f& from, Index stride)
|
||||
{
|
||||
- float EIGEN_ALIGN16 ai[4];
|
||||
+ EIGEN_ALIGN16 float ai[4];
|
||||
pstore<float>((float *)ai, from);
|
||||
to[0*stride] = ai[0];
|
||||
to[1*stride] = ai[1];
|
||||
@@ -785,7 +785,7 @@ template<> EIGEN_STRONG_INLINE Packet4f ploaddup<Packet4f>(const float* from)
|
||||
return p;
|
||||
}
|
||||
|
||||
-template<> EIGEN_STRONG_INLINE float pfirst<Packet4f>(const Packet4f& a) { float EIGEN_ALIGN16 x[2]; vec_st2f(a.v4f[0], &x[0]); return x[0]; }
|
||||
+template<> EIGEN_STRONG_INLINE float pfirst<Packet4f>(const Packet4f& a) { EIGEN_ALIGN16 float x[2]; vec_st2f(a.v4f[0], &x[0]); return x[0]; }
|
||||
|
||||
template<> EIGEN_STRONG_INLINE Packet4f preverse(const Packet4f& a)
|
||||
{
|
||||
@@ -943,7 +943,7 @@ pbroadcast4<Packet4f>(const float *a,
|
||||
|
||||
template<> EIGEN_DEVICE_FUNC inline Packet4f pgather<float, Packet4f>(const float* from, Index stride)
|
||||
{
|
||||
- float EIGEN_ALIGN16 af[4];
|
||||
+ EIGEN_ALIGN16 float af[4];
|
||||
af[0] = from[0*stride];
|
||||
af[1] = from[1*stride];
|
||||
af[2] = from[2*stride];
|
||||
@@ -953,7 +953,7 @@ template<> EIGEN_DEVICE_FUNC inline Packet4f pgather<float, Packet4f>(const floa
|
||||
|
||||
template<> EIGEN_DEVICE_FUNC inline void pscatter<float, Packet4f>(float* to, const Packet4f& from, Index stride)
|
||||
{
|
||||
- float EIGEN_ALIGN16 af[4];
|
||||
+ EIGEN_ALIGN16 float af[4];
|
||||
pstore<float>((float*)af, from);
|
||||
to[0*stride] = af[0];
|
||||
to[1*stride] = af[1];
|
||||
@@ -978,7 +978,7 @@ template<> EIGEN_STRONG_INLINE Packet4f pround<Packet4f> (const Packet4f& a) { r
|
||||
template<> EIGEN_STRONG_INLINE Packet4f pceil<Packet4f> (const Packet4f& a) { return vec_ceil(a); }
|
||||
template<> EIGEN_STRONG_INLINE Packet4f pfloor<Packet4f> (const Packet4f& a) { return vec_floor(a); }
|
||||
template<> EIGEN_STRONG_INLINE Packet4f pabs<Packet4f> (const Packet4f& a) { return vec_abs(a); }
|
||||
-template<> EIGEN_STRONG_INLINE float pfirst<Packet4f>(const Packet4f& a) { float EIGEN_ALIGN16 x[4]; pstore(x, a); return x[0]; }
|
||||
+template<> EIGEN_STRONG_INLINE float pfirst<Packet4f>(const Packet4f& a) { EIGEN_ALIGN16 float x[4]; pstore(x, a); return x[0]; }
|
||||
|
||||
template<> EIGEN_STRONG_INLINE Packet4f ploaddup<Packet4f>(const float* from)
|
||||
{
|
||||
--
|
||||
GitLab
|
||||
|
353
extras/eigen3/eigen3.spec
Normal file
353
extras/eigen3/eigen3.spec
Normal file
@ -0,0 +1,353 @@
|
||||
# The (empty) main package is arch, to have the package built and tests run
|
||||
# on all arches, but the actual result package is the noarch -devel subpackge.
|
||||
# Debuginfo packages are disabled to prevent rpmbuild from generating an empty
|
||||
# debuginfo package for the empty main package.
|
||||
%global debug_package %{nil}
|
||||
|
||||
%undefine __cmake_in_source_build
|
||||
|
||||
# FIXME ICE on ppc64le when buildings docs with optflags
|
||||
%ifarch ppc64le
|
||||
%global optflags %{nil}
|
||||
%endif
|
||||
|
||||
|
||||
%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
|
||||
%global blaslib flexiblas
|
||||
%global cmake_blas_flags -DBLA_VENDOR=FlexiBLAS
|
||||
%else
|
||||
%global blaslib openblas
|
||||
%global blasvar o
|
||||
%global cmake_blas_flags -DBLAS_LIBRARIES=%{_libdir}/lib%{blaslib}%{blasvar}.so
|
||||
%endif
|
||||
|
||||
%bcond_with sparsehash
|
||||
%bcond_with suitesparse
|
||||
%bcond_with SuperLU
|
||||
%bcond_with scotch
|
||||
%bcond_with metis
|
||||
|
||||
Name: eigen3
|
||||
Version: 3.4.0
|
||||
Release: 2%{?dist}
|
||||
Summary: A lightweight C++ template library for vector and matrix math
|
||||
|
||||
License: ASL 2.0 and MPLv2.0 and LGPLv2+ and BSD and Minpack
|
||||
URL: http://eigen.tuxfamily.org/index.php?title=Main_Page
|
||||
Source0: https://gitlab.com/libeigen/eigen/-/archive/%{version}/eigen-%{version}.tar.bz2
|
||||
# Upstream patches requested by a partner or customer:
|
||||
Patch0: 0001-fix_zvector_build.patch
|
||||
Patch1: 0002-zvector_move_alignas_qualifier_to_come_first.patch
|
||||
|
||||
BuildRequires: %{blaslib}-devel
|
||||
BuildRequires: fftw-devel
|
||||
BuildRequires: gmp-devel
|
||||
BuildRequires: gsl-devel
|
||||
BuildRequires: mpfr-devel
|
||||
%{?with_sparsehash:BuildRequires: sparsehash-devel}
|
||||
%{?with_suitesparse:BuildRequires: suitesparse-devel}
|
||||
BuildRequires: gcc-gfortran
|
||||
%{?with_SuperLU:BuildRequires: SuperLU-devel}
|
||||
%{?with_scotch:BuildRequires: scotch-devel}
|
||||
%{?with_metis:BuildRequires: metis-devel}
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: graphviz
|
||||
BuildRequires: tex(latex)
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: A lightweight C++ template library for vector and matrix math
|
||||
BuildArch: noarch
|
||||
# -devel subpkg only atm, compat with other distros
|
||||
Provides: %{name} = %{version}-%{release}
|
||||
# not *strictly* a -static pkg, but the results are the same
|
||||
Provides: %{name}-static = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
%{summary}.
|
||||
|
||||
%package doc
|
||||
Summary: Developer documentation for Eigen
|
||||
Requires: %{name}-devel = %{version}-%{release}
|
||||
BuildArch: noarch
|
||||
|
||||
%description doc
|
||||
Developer documentation for Eigen.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n eigen-%{version}
|
||||
|
||||
|
||||
%build
|
||||
%cmake \
|
||||
-DINCLUDE_INSTALL_DIR=%{_includedir}/%{name} \
|
||||
%{cmake_blas_flags} \
|
||||
%{?with_SuperLU:-DSUPERLU_INCLUDES=%{_includedir}/SuperLU} \
|
||||
%{?with_scotch:-DSCOTCH_INCLUDES=%{_includedir} -DSCOTCH_LIBRARIES="scotch"} \
|
||||
%{?with_metis:-DMETIS_INCLUDES=%{_includedir} -DMETIS_LIBRARIES="metis"} \
|
||||
-DCMAKEPACKAGE_INSTALL_DIR=%{_datadir}/cmake/%{name} \
|
||||
-DEIGEN_TEST_CXX11=ON
|
||||
|
||||
%cmake_build
|
||||
%cmake_build --target doc
|
||||
|
||||
rm -f %{_vpath_builddir}/doc/html/installdox
|
||||
rm -f %{_vpath_builddir}/doc/html/unsupported/installdox
|
||||
|
||||
|
||||
%install
|
||||
%cmake_install
|
||||
|
||||
|
||||
%check
|
||||
# Test fail to build due to compiler crashes
|
||||
#cmake_build --target buildtests
|
||||
#ctest
|
||||
|
||||
|
||||
%files devel
|
||||
%license COPYING.README COPYING.APACHE COPYING.BSD COPYING.MPL2 COPYING.GPL COPYING.LGPL COPYING.MINPACK
|
||||
%{_includedir}/%{name}
|
||||
%{_datadir}/cmake/%{name}
|
||||
%{_datadir}/pkgconfig/%{name}.pc
|
||||
|
||||
%files doc
|
||||
%doc %{_vpath_builddir}/doc/html
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon May 15 2023 Jiri Kucera <jkucera@redhat.com> - 3.4.0-2
|
||||
- Backport upstream patches
|
||||
Resolves: #2137486
|
||||
|
||||
* Wed Feb 16 2022 Jiri Kucera <jkucera@redhat.com> - 3.4.0-1
|
||||
- Update to 3.4.0
|
||||
Resolves: #2032423
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 3.3.9-8
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Mon Jul 12 2021 Jiri Kucera <jkucera@redhat.com> - 3.3.9-7
|
||||
- Remove glew-devel BR
|
||||
Resolves: #1981397
|
||||
|
||||
* Wed Jun 30 2021 Jiri Kucera <jkucera@redhat.com> - 3.3.9-6
|
||||
- Added missing Minpack license
|
||||
Dropped unnecessary dependencies
|
||||
Resolves: #1967481
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 3.3.9-5
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.9-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jan 19 2021 Jan Grulich <jgrulich@redhat.com> - 3.3.9-3
|
||||
- Drop qt dependency on RHEL 8 and higher
|
||||
|
||||
* Tue Jan 19 2021 Sandro Mani <manisandro@gmail.com> - 3.3.9-2
|
||||
- Backport fix for conflicting declarations of log1p
|
||||
|
||||
* Sun Dec 06 2020 Sandro Mani <manisandro@gmail.com> - 3.3.9-1
|
||||
- Update to 3.3.9
|
||||
|
||||
* Mon Oct 05 2020 Sandro Mani <manisandro@gmail.com> - 3.3.8-2
|
||||
- Drop reference to undefined Eigen::eigen_assert_exception
|
||||
|
||||
* Mon Oct 05 2020 Sandro Mani <manisandro@gmail.com> - 3.3.8-1
|
||||
- Update to 3.3.8
|
||||
|
||||
* Tue Sep 01 2020 Iñaki Úcar <iucar@fedoraproject.org> - 3.3.7-7
|
||||
- https://fedoraproject.org/wiki/Changes/FlexiBLAS_as_BLAS/LAPACK_manager
|
||||
|
||||
* Sat Aug 29 2020 Fabio Valentini <decathorpe@gmail.com> - 3.3.7-6
|
||||
- Adapt to CMake macros changes in fedora 33+.
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.7-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.7-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Dec 25 2018 Sandro Mani <manisandro@gmail.com> - 3.3.7-1
|
||||
- Update to 3.3.7
|
||||
- Modernize spec
|
||||
- Add doc
|
||||
|
||||
* Mon Dec 10 2018 Sandro Mani <manisandro@gmail.com> - 3.3.6-1
|
||||
- Update to 3.3.6
|
||||
|
||||
* Thu Sep 06 2018 Rex Dieter <rdieter@fedoraproject.org> - 3.3.5-2
|
||||
- backport upstream fix for step FTBFS (#1619860)
|
||||
|
||||
* Thu Jul 26 2018 Sandro Mani <manisandro@gmail.com> - 3.3.5-1
|
||||
- Update to 3.3.5
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.4-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri May 25 2018 Björn Esser <besser82@fedoraproject.org> - 3.3.4-6
|
||||
- Fix compilation of Jacobi rotations with ARM NEON, some
|
||||
specializations of internal::conj_helper were missing
|
||||
|
||||
* Sun Feb 18 2018 Sandro Mani <manisandro@gmail.com> - 3.3.4-5
|
||||
- Add missing BR: gcc-c++, make
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.4-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Jun 19 2017 Sandro Mani <manisandro@gmail.com> - 3.3.4-1
|
||||
- Update to 3.3.4
|
||||
|
||||
* Wed Feb 22 2017 Sandro Mani <manisandro@gmail.com> - 3.3.3-1
|
||||
- Update to 3.3.3
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Sun Jan 22 2017 Sandro Mani <manisandro@gmail.com> - 3.3.2-1
|
||||
- Update to 3.3.2
|
||||
|
||||
* Wed Dec 28 2016 Rich Mattes <richmattes@gmail.com> - 3.3.1-1
|
||||
- Update to 3.3.1 (rhbz#1408538)
|
||||
|
||||
* Wed Nov 23 2016 Rich Mattes <richmattes@gmail.com> - 3.3.0-1
|
||||
- Update to 3.3.0
|
||||
- Stop renaming tarball - just use upstream tarball
|
||||
|
||||
* Tue Oct 04 2016 Sandro Mani <manisandro@gmail.com> - 3.2.10-1
|
||||
- Update to 3.2.10
|
||||
|
||||
* Tue Jul 19 2016 Sandro Mani <manisandro@gmail.com> - 3.2.9-1
|
||||
- Update to 3.2.9
|
||||
|
||||
* Sat Feb 20 2016 Sandro Mani <manisandro@gmail.com> - 3.2.8-1
|
||||
- Update to 3.2.8
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.7-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Nov 06 2015 Sandro Mani <manisandro@gmail.com> - 3.2.7-3
|
||||
- Again: Fix incorrect include path in pkgconfig file
|
||||
|
||||
* Fri Nov 06 2015 Sandro Mani <manisandro@gmail.com> - 3.2.7-2
|
||||
- Fix incorrect include path in pkgconfig file
|
||||
|
||||
* Thu Nov 05 2015 Sandro Mani <manisandro@gmail.com> - 3.2.7-1
|
||||
- Update to release 3.2.7
|
||||
|
||||
* Thu Oct 01 2015 Sandro Mani <manisandro@gmail.com> - 3.2.6-1
|
||||
- Update to release 3.2.6
|
||||
|
||||
* Fri Aug 21 2015 Rich Mattes <richmattes@gmail.com> - 3.2.5-2
|
||||
- Apply patch to install FindEigen3.cmake
|
||||
|
||||
* Tue Jun 16 2015 Sandro Mani <manisandro@gmail.com> - 3.2.5-1
|
||||
- Update to release 3.2.5
|
||||
|
||||
* Thu Jan 22 2015 Sandro Mani <manisandro@gmail.com> - 3.2.4-1
|
||||
- Update to release 3.2.4
|
||||
|
||||
* Mon Jan 05 2015 Rich Mattes <richmattes@gmail.com> - 3.2.3-2
|
||||
- Backport upstream Rotation2D fix
|
||||
|
||||
* Thu Dec 18 2014 Sandro Mani <manisandro@gmail.com> - 3.2.3-1
|
||||
- Update to release 3.2.3
|
||||
- Drop upstreamed eigen3-ppc64.patch
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Mon Aug 04 2014 Sandro Mani <manisandro@gmail.com> - 3.2.2-1
|
||||
- Update to release 3.2.2
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Tue Mar 11 2014 Orion Poplawski <orion@cora.nwra.com> - 3.2.1-4
|
||||
- Add ppc64 support
|
||||
|
||||
* Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-3
|
||||
- Make doc package noarch
|
||||
|
||||
* Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-2
|
||||
- Split off doc to a separate package
|
||||
|
||||
* Wed Feb 26 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-1
|
||||
- Udpate to release 3.2.1
|
||||
|
||||
* Sun Aug 11 2013 Sandro Mani <manisandro@gmail.com> - 3.2-3
|
||||
- Build and run tests
|
||||
- Drop -DBLAS_LIBRARIES_DIR, not used
|
||||
- Add some BR to enable tests of corresponding backends
|
||||
- spec cleanup
|
||||
|
||||
* Wed Jul 24 2013 Sandro Mani <manisandro@gmail.com> - 3.2-1
|
||||
- Update to release 3.2
|
||||
|
||||
* Sat Jun 29 2013 Rich Mattes <richmattes@gmail.com> - 3.1.3-2
|
||||
- Add upstream patch to fix malloc/free bugs (rhbz#978971)
|
||||
|
||||
* Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 3.1.3-1
|
||||
- Update to release 3.1.3
|
||||
- Add patch for unused typedefs warning with gcc4.8
|
||||
|
||||
* Tue Mar 05 2013 Rich Mattes <richmattes@gmail.com> - 3.1.2-1
|
||||
- Update to release 3.1.2
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sat Jul 28 2012 Tim Niemueller <tim@niemueller.de> - 3.0.6-1
|
||||
- Update to release 3.0.6 (fixes GCC 4.7 warnings)
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sun Mar 11 2012 Rich Mattes <richmattes@gmail.com> - 3.0.5-1
|
||||
- Update to release 3.0.5
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Sun Dec 18 2011 Rich Mattes <richmattes@gmail.com> - 3.0.4-1
|
||||
- Update to release 3.0.4
|
||||
|
||||
* Tue Nov 15 2011 Rich Mattes <richmattes@gmail.com> - 3.0.3-1
|
||||
- Update to release 3.0.3
|
||||
|
||||
* Sun Apr 17 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-2
|
||||
- Patched sources to fix build failure
|
||||
- Removed fixes made upstream
|
||||
- Added project name to source tarball filename
|
||||
|
||||
* Sat Mar 26 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-1
|
||||
- Update to release 3.0.0
|
||||
|
||||
* Tue Jan 25 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.2.beta2
|
||||
- Change blas-devel buildrequirement to atlas-devel
|
||||
- Don't make the built-in experimental blas library
|
||||
|
||||
* Mon Jan 24 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.1.beta2
|
||||
- Initial package
|
Loading…
x
Reference in New Issue
Block a user