rx-libwebp: update to 1.4.0
This commit is contained in:
parent
a52bcd1cac
commit
3f95aa6f39
@ -1,7 +1,7 @@
|
|||||||
diff -rupN --no-dereference libwebp-1.3.2/CMakeLists.txt libwebp-1.3.2-new/CMakeLists.txt
|
diff -rupN --no-dereference libwebp-1.4.0/CMakeLists.txt libwebp-1.4.0-new/CMakeLists.txt
|
||||||
--- libwebp-1.3.2/CMakeLists.txt 2023-09-28 20:47:39.567153346 +0200
|
--- libwebp-1.4.0/CMakeLists.txt 2024-04-14 15:30:20.053730120 +0200
|
||||||
+++ libwebp-1.3.2-new/CMakeLists.txt 2023-09-28 20:47:39.573153410 +0200
|
+++ libwebp-1.4.0-new/CMakeLists.txt 2024-04-14 15:30:20.056730140 +0200
|
||||||
@@ -738,7 +738,7 @@ install(
|
@@ -784,7 +784,7 @@ install(
|
||||||
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
||||||
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
||||||
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
|
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rupN --no-dereference libwebp-1.3.2/CMakeLists.txt libwebp-1.3.2-new/CMakeLists.txt
|
diff -rupN --no-dereference libwebp-1.4.0/CMakeLists.txt libwebp-1.4.0-new/CMakeLists.txt
|
||||||
--- libwebp-1.3.2/CMakeLists.txt 2023-09-14 00:11:07.000000000 +0200
|
--- libwebp-1.4.0/CMakeLists.txt 2024-04-12 22:48:48.000000000 +0200
|
||||||
+++ libwebp-1.3.2-new/CMakeLists.txt 2023-09-28 20:47:39.497152607 +0200
|
+++ libwebp-1.4.0-new/CMakeLists.txt 2024-04-14 15:30:19.981729641 +0200
|
||||||
@@ -564,8 +564,8 @@ endif()
|
@@ -582,8 +582,8 @@ endif()
|
||||||
|
|
||||||
if(WEBP_BUILD_VWEBP)
|
if(WEBP_BUILD_VWEBP)
|
||||||
# vwebp
|
# vwebp
|
||||||
@ -12,7 +12,7 @@ diff -rupN --no-dereference libwebp-1.3.2/CMakeLists.txt libwebp-1.3.2-new/CMake
|
|||||||
include_directories(${WEBP_DEP_IMG_INCLUDE_DIRS})
|
include_directories(${WEBP_DEP_IMG_INCLUDE_DIRS})
|
||||||
parse_makefile_am(${CMAKE_CURRENT_SOURCE_DIR}/examples "VWEBP_SRCS" "vwebp")
|
parse_makefile_am(${CMAKE_CURRENT_SOURCE_DIR}/examples "VWEBP_SRCS" "vwebp")
|
||||||
add_executable(vwebp ${VWEBP_SRCS})
|
add_executable(vwebp ${VWEBP_SRCS})
|
||||||
@@ -573,7 +573,7 @@ if(WEBP_BUILD_VWEBP)
|
@@ -591,7 +591,7 @@ if(WEBP_BUILD_VWEBP)
|
||||||
vwebp
|
vwebp
|
||||||
${OPENGL_LIBRARIES}
|
${OPENGL_LIBRARIES}
|
||||||
exampleutil
|
exampleutil
|
||||||
@ -21,10 +21,10 @@ diff -rupN --no-dereference libwebp-1.3.2/CMakeLists.txt libwebp-1.3.2-new/CMake
|
|||||||
imageioutil
|
imageioutil
|
||||||
webp
|
webp
|
||||||
webpdemux)
|
webpdemux)
|
||||||
diff -rupN --no-dereference libwebp-1.3.2/examples/vwebp.c libwebp-1.3.2-new/examples/vwebp.c
|
diff -rupN --no-dereference libwebp-1.4.0/examples/vwebp.c libwebp-1.4.0-new/examples/vwebp.c
|
||||||
--- libwebp-1.3.2/examples/vwebp.c 2023-09-14 00:11:07.000000000 +0200
|
--- libwebp-1.4.0/examples/vwebp.c 2024-04-12 22:48:48.000000000 +0200
|
||||||
+++ libwebp-1.3.2-new/examples/vwebp.c 2023-09-28 20:47:39.498152618 +0200
|
+++ libwebp-1.4.0-new/examples/vwebp.c 2024-04-14 15:30:19.981729641 +0200
|
||||||
@@ -27,7 +27,7 @@
|
@@ -28,7 +28,7 @@
|
||||||
#if defined(HAVE_GLUT_GLUT_H)
|
#if defined(HAVE_GLUT_GLUT_H)
|
||||||
#include <GLUT/glut.h>
|
#include <GLUT/glut.h>
|
||||||
#else
|
#else
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rupN --no-dereference libwebp-1.3.2/CMakeLists.txt libwebp-1.3.2-new/CMakeLists.txt
|
diff -rupN --no-dereference libwebp-1.4.0/CMakeLists.txt libwebp-1.4.0-new/CMakeLists.txt
|
||||||
--- libwebp-1.3.2/CMakeLists.txt 2023-09-28 20:47:39.529152945 +0200
|
--- libwebp-1.4.0/CMakeLists.txt 2024-04-14 15:30:20.015729868 +0200
|
||||||
+++ libwebp-1.3.2-new/CMakeLists.txt 2023-09-28 20:47:39.535153009 +0200
|
+++ libwebp-1.4.0-new/CMakeLists.txt 2024-04-14 15:30:20.020729901 +0200
|
||||||
@@ -286,6 +286,9 @@ macro(set_version FILE TARGET_NAME NAME_
|
@@ -301,6 +301,9 @@ macro(set_version FILE TARGET_NAME NAME_
|
||||||
MACHO_CURRENT_VERSION
|
MACHO_CURRENT_VERSION
|
||||||
${LIBWEBP_MACHO_COMPATIBILITY_VERSION}.${LT_REVISION})
|
${LIBWEBP_MACHO_COMPATIBILITY_VERSION}.${LT_REVISION})
|
||||||
endif()
|
endif()
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rupN --no-dereference libwebp-1.3.2/CMakeLists.txt libwebp-1.3.2-new/CMakeLists.txt
|
diff -rupN --no-dereference libwebp-1.4.0/CMakeLists.txt libwebp-1.4.0-new/CMakeLists.txt
|
||||||
--- libwebp-1.3.2/CMakeLists.txt 2023-09-28 20:47:39.607153769 +0200
|
--- libwebp-1.4.0/CMakeLists.txt 2024-04-14 15:30:20.089730360 +0200
|
||||||
+++ libwebp-1.3.2-new/CMakeLists.txt 2023-09-28 20:47:39.610153800 +0200
|
+++ libwebp-1.4.0-new/CMakeLists.txt 2024-04-14 15:30:20.093730386 +0200
|
||||||
@@ -112,11 +112,11 @@ endif()
|
@@ -114,11 +114,11 @@ endif()
|
||||||
include(cmake/deps.cmake)
|
include(cmake/deps.cmake)
|
||||||
include(GNUInstallDirs)
|
include(GNUInstallDirs)
|
||||||
|
|
||||||
|
@ -14,7 +14,7 @@
|
|||||||
|
|
||||||
|
|
||||||
Name: rx-libwebp
|
Name: rx-libwebp
|
||||||
Version: 1.3.2
|
Version: 1.4.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://webmproject.org/
|
URL: http://webmproject.org/
|
||||||
Summary: Library and tools for the WebP graphics format
|
Summary: Library and tools for the WebP graphics format
|
||||||
@ -25,16 +25,12 @@ Source1: libwebp_jni_example.java
|
|||||||
|
|
||||||
# Fix build with freeglut
|
# Fix build with freeglut
|
||||||
Patch0: libwebp-freeglut.patch
|
Patch0: libwebp-freeglut.patch
|
||||||
# Add version suffix to mingw libraries
|
|
||||||
#Patch1: libwebp-mingw-libsuffix.patch
|
|
||||||
# Fix cmake module install location
|
# Fix cmake module install location
|
||||||
Patch2: libwebp-cmakedir.patch
|
Patch2: libwebp-cmakedir.patch
|
||||||
# Kill rpath
|
# Kill rpath
|
||||||
#Patch3: libwebp-rpath.patch
|
Patch3: libwebp-rpath.patch
|
||||||
# Backport upstream fix for CVE-2023-5129
|
|
||||||
Patch5: https://github.com/webmproject/libwebp/commit/95ea5226c870449522240ccff26f0b006037c520.patch
|
|
||||||
|
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: rx-libjpeg-turbo-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: giflib-devel
|
BuildRequires: giflib-devel
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
@ -44,6 +40,9 @@ BuildRequires: swig
|
|||||||
BuildRequires: ninja-build
|
BuildRequires: ninja-build
|
||||||
BuildRequires: freeglut-devel
|
BuildRequires: freeglut-devel
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
|
BuildRequires: clang
|
||||||
|
|
||||||
|
Requires: rx-libjpeg-turbo
|
||||||
|
|
||||||
%description
|
%description
|
||||||
WebP is an image format that does lossy compression of digital
|
WebP is an image format that does lossy compression of digital
|
||||||
@ -103,6 +102,9 @@ export CFLAGS="%{optflags} -frename-registers"
|
|||||||
%endif
|
%endif
|
||||||
export LDFLAGS="%{build_ldflags} -L%{_libdir} -Wl,-rpath=%{_libdir}"
|
export LDFLAGS="%{build_ldflags} -L%{_libdir} -Wl,-rpath=%{_libdir}"
|
||||||
|
|
||||||
|
export CC=clang
|
||||||
|
export CXX=clang++
|
||||||
|
|
||||||
# Native build
|
# Native build
|
||||||
%cmake
|
%cmake
|
||||||
%cmake_build
|
%cmake_build
|
||||||
@ -117,10 +119,11 @@ swig -ignoremissing -I../src -java \
|
|||||||
-outdir java/com/google/webp \
|
-outdir java/com/google/webp \
|
||||||
-o libwebp_java_wrap.c libwebp.swig
|
-o libwebp_java_wrap.c libwebp.swig
|
||||||
|
|
||||||
gcc %{__global_ldflags} %{optflags} -shared \
|
clang %{__global_ldflags} %(echo %{optflags} | sed 's/-fcf-protection//')-shared -fPIC \
|
||||||
-I/usr/lib/jvm/java/include \
|
-I/usr/lib/jvm/java/include \
|
||||||
-I/usr/lib/jvm/java/include/linux \
|
-I/usr/lib/jvm/java/include/linux \
|
||||||
-I../src \
|
-I../src \
|
||||||
|
-L.. \
|
||||||
-L../src/.libs -lwebp libwebp_java_wrap.c \
|
-L../src/.libs -lwebp libwebp_java_wrap.c \
|
||||||
-o libwebp_jni.so
|
-o libwebp_jni.so
|
||||||
|
|
||||||
@ -186,6 +189,9 @@ done
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 7 2024 Raven <raven@sysadmins.ws> - 1.4.0-1
|
||||||
|
- Update to 1.4.0
|
||||||
|
|
||||||
* Wed Dec 20 2023 Raven <raven@sysadmins.ws> - 1.3.2-1
|
* Wed Dec 20 2023 Raven <raven@sysadmins.ws> - 1.3.2-1
|
||||||
- Update to 1.3.2
|
- Update to 1.3.2
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user