wine: import from source RPM

This commit is contained in:
Raven 2024-04-18 09:40:33 +06:00
parent 605002842f
commit 2ad4f655ea
23 changed files with 3332 additions and 0 deletions

View File

@ -0,0 +1 @@
/usr/lib/wine/

View File

@ -0,0 +1 @@
/usr/lib64/wine/

View File

@ -0,0 +1,44 @@
Wine directory structure used in Fedora Linux:
==============================================
${HOME}/.wine/drive_c is the root directory (aka C: drive) wine looks for
by default. It is created with (empty) C:\windows and C:\windows\system
directories, needed to operate Wine without an existing Windows
installation, if it does not already exist.
If you want to use Wine with an existing Windows installation that is
mounted, for example, in /mnt/windows-c, change the symlink
${HOME}/.wine/dosdevices/c: to point to /mnt/windows-c instead of the
defaults set by installation.
If you do this, you can safely remove ${HOME}/.wine/drive_c.
(Alternatively, just mount your Windows partition to ${HOME}/.wine/drive_c.)
Wine bugs:
==========
If you find a bug, please take the time to move your ${HOME}/.wine directory
someplace and try with a fresh version (like mv ${HOME}/.wine{,-save}). If the
bug is still there look through https://bugzilla.redhat.com and see if the bug
has already been reported. In case it was not please report it.
CJK support:
============
Fedora carries a modified wine.inf file with support for cjk complying to the
fedora default fonts (see
http://tagoh.fedorapeople.org/fonts/fedora-current-defaultfonts.html)
wine does _not_ pull in the cjk font packages automatically. The following
font packages may need to be installed depending on your locale:
zh_CN:
wqy-microhei
jp:
vlgothic-fonts
vlgothic-p-fonts
ipa-mincho-fonts
ipa-pmincho-fonts
ko:
nhn-nanum-gothic-fonts
nhn-nanum-myeongjo-fonts.noarch

View File

@ -0,0 +1,19 @@
= wine-tahoma-fonts =
Wine provides the wine tahoma font family. In fedora embedded bitmaps are
turned off per default (/etc/fonts/conf.d/20-wine-tahoma-nobitmaps.conf) as
this will provide smoother letters for most users.
If you do not like the wine tahoma font experience but want to keep it
installed you can turn it of by adding the following to ~/.fonts.conf or by
adding a file containing the following to ~/.fonts.conf.d/:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!-- Reject wine-tahoma-fonts -->
<selectfont>
<rejectfont>
<glob>*/wine-tahoma-fonts/*</glob>
</rejectfont>
</selectfont>
</fontconfig>

View File

@ -0,0 +1,22 @@
Index: wine-1.7.22/loader/wine.inf.in
===================================================================
--- wine-1.7.22.orig/loader/wine.inf.in
+++ wine-1.7.22/loader/wine.inf.in
@@ -568,6 +568,17 @@ HKLM,%FontSubStr%,"Times New Roman CE,23
HKLM,%FontSubStr%,"Times New Roman CYR,204",,"Times New Roman,204"
HKLM,%FontSubStr%,"Times New Roman Greek,161",,"Times New Roman,161"
HKLM,%FontSubStr%,"Times New Roman TUR,162",,"Times New Roman,162"
+HKCU,Software\Wine\Fonts\Replacements,"SimSun",,"WenQuanYi Zen Hei Sharp"
+HKCU,Software\Wine\Fonts\Replacements,"PMingLiU",,"WenQuanYi Zen Hei Sharp"
+HKCU,Software\Wine\Fonts\Replacements,"MS Gothic",,"VL Gothic"
+HKCU,Software\Wine\Fonts\Replacements,"MS PGothic",,"VL PGothic"
+HKCU,Software\Wine\Fonts\Replacements,"MS UI Gothic",,"VL Gothic"
+HKCU,Software\Wine\Fonts\Replacements,"MS Mincho",,"IPAMincho"
+HKCU,Software\Wine\Fonts\Replacements,"MS PMincho",,"IPAPMincho"
+HKCU,Software\Wine\Fonts\Replacements,"Batang",,"NanumMyeongjo"
+HKCU,Software\Wine\Fonts\Replacements,"Dotum",,"NanumGothic"
+HKCU,Software\Wine\Fonts\Replacements,"Gulim",,"NanumGothic"
+HKCU,Software\Wine\Fonts\Replacements,"Arial Unicode MS",,"Droid Sans Fallback"
HKLM,System\CurrentControlSet\Hardware Profiles\Current\Software\Fonts,"LogPixels",0x10003,0x00000060
[MCI]

View File

@ -0,0 +1,9 @@
[Desktop Entry]
Type=Application
Name=Windows Installer File
Name[ar]=مثبت حزم واين
Exec=wine %f
MimeType=application/x-ole-storage;text/mspg-legacyinfo;
Hidden=true
StartupNotify=true
StartupWMClass=msiexec.exe

View File

@ -0,0 +1,12 @@
[Desktop Entry]
Name=Notepad
Comment=Text Editor
Name[ar]=مفكرة
Comment[ar]=محرر النّصوص مفكرة واين
Exec=notepad
Icon=notepad
Terminal=false
Type=Application
StartupNotify=true
StartupWMClass=notepad.exe
Categories=X-Wine;

View File

@ -0,0 +1,12 @@
[Desktop Entry]
Name=Wine OLE View
Comment=Windows OLE View
Name[ar]=عارض العناصر
Comment[ar]=لعرض العناصر البيئية في واين
Exec=wine oleview.exe
Icon=wine
Terminal=false
Type=Application
StartupNotify=true
StartupWMClass=oleview.exe
Categories=X-Wine;

View File

@ -0,0 +1,12 @@
[Desktop Entry]
Name=Regedit
Comment=Wine registry editor
Name[ar]=محرر السّجل
Comment[ar]=محرر لسجلات واين
Exec=regedit
Icon=regedit
Terminal=false
Type=Application
StartupNotify=true
StartupWMClass=regedit.exe
Categories=X-Wine;

View File

@ -0,0 +1,11 @@
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!-- Disable embedded bitmaps in the Tahoma font -->
<match target="font">
<test name="family"><string>Tahoma</string></test>
<edit name="embeddedbitmap"><bool>false</bool></edit>
</match>
</fontconfig>

View File

@ -0,0 +1,12 @@
[Desktop Entry]
Name=Wine Software Uninstaller
Comment=Interface to uninstall software
Name[ar]=مزيل التطبيقات من واين
Comment[ar]=واجهة إزالة التّطبيقات من واين
Exec=wine uninstaller.exe
Icon=msiexec
Terminal=false
Type=Application
StartupNotify=true
StartupWMClass=uninstaller.exe
Categories=X-Wine;

View File

@ -0,0 +1,10 @@
[Desktop Entry]
Name=Wine Boot
Comment=Simulate restart
Name[ar]=إقلاع واين
Comment[ar]=محاكاة إعادة التشغيل لواين
Exec=wineboot
Icon=wine
Terminal=false
Type=Application
Categories=X-Wine;

View File

@ -0,0 +1,12 @@
[Desktop Entry]
Name=Wine Configuration
Comment=Interface to set wine parameters
Name[ar]=إعدادات واين
Comment[ar]=لوحة تحكم بمنظومة واين
Exec=winecfg
Icon=winecfg
Terminal=false
Type=Application
StartupNotify=true
StartupWMClass=winecfg.exe
Categories=X-Wine;

View File

@ -0,0 +1,10 @@
[Desktop Entry]
Name=Wine File
Comment=Wine File Browser
Name[ar]=مدير ملفات واين
Comment[ar]=إدارة الملفات بطريقة واين
Exec=winefile
Icon=winefile
Terminal=false
Type=Application
Categories=X-Wine;

View File

@ -0,0 +1,12 @@
[Desktop Entry]
Name=WineMine
Comment=Wine Minesweeper
Name[ar]=كانسة ألغام واين
Comment[ar]=لعبة كانسة ألغام واين
Exec=winemine
Icon=winemine
Terminal=false
Type=Application
StartupNotify=true
StartupWMClass=winemine.exe
Categories=Game;LogicGame;

View File

@ -0,0 +1,12 @@
[Desktop Entry]
Name=Wine Help
Comment=Windows Help Browser
Name[ar]=أداة المساعدة في واين
Comment[ar]=استعراض ملفات المساعدة بتنسيقات وندوز
Exec=wine winhlp32.exe
Icon=winhelp
Terminal=false
Type=Application
StartupNotify=true
StartupWMClass=winhlp32.exe
Categories=X-Wine;

View File

@ -0,0 +1,12 @@
[Desktop Entry]
Name=Wine Wordpad
Comment=Text Editor
Name[ar]=دفتر واين
Comment[ar]=محرر النّصوص دفتر واين
Exec=wine wordpad.exe
Icon=wordpad
Terminal=false
Type=Application
StartupNotify=true
StartupWMClass=wordpad.exe
Categories=X-Wine;

View File

@ -0,0 +1,25 @@
<?xml version="1.0" encoding="UTF-8"?>
<component type="desktop">
<id>wine.desktop</id>
<metadata_license>CC0-1.0</metadata_license>
<project_license>LGPLv2+</project_license>
<name>Wine</name>
<summary>A compatibility layer for Windows applications</summary>
<description>
<p>
Wine (originally an acronym for "Wine Is Not an Emulator") is a compatibility
layer capable of running Windows applications on several POSIX-compliant operating
systems, such as Linux, macOS, &amp; BSD. Instead of simulating internal Windows
logic like a virtual machine or emulator, Wine translates Windows API calls into
POSIX calls on-the-fly, eliminating the performance and memory penalties of other
methods and allowing you to cleanly integrate Windows applications into your desktop.
</p>
</description>
<url type="homepage">https://www.winehq.org/</url>
<url type="bugtracker">https://bugs.winehq.org/</url>
<url type="faq">https://wiki.winehq.org/FAQ</url>
<url type="help">https://wiki.winehq.org/</url>
<url type="donation">https://www.winehq.org/donate</url>
<url type="translate">https://wiki.winehq.org/Translating</url>
</component>

View File

@ -0,0 +1,5 @@
[Desktop Entry]
Encoding=UTF-8
Type=Directory
Name=Wine
Icon=wine

View File

@ -0,0 +1,89 @@
#!/bin/sh
#
# wine Allow users to run Windows(tm) applications by just clicking on them
# (or typing ./file.exe)
#
# chkconfig: 35 98 10
# description: Allow users to run Windows(tm) applications by just clicking \
# on them (or typing ./file.exe)
### BEGIN INIT INFO
# Provides: wine-binfmt
# Required-Start:
# Required-Stop:
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Add and remove wine binary handler
# Description: Allow users to run Windows(tm) applications by just clicking
# on them (or typing ./file.exe)
### END INIT INFO
. /etc/rc.d/init.d/functions
RETVAL=0
start() {
# fix bug on changing runlevels #213230
if [ -e /proc/sys/fs/binfmt_misc/windows ]; then
echo -n $"Binary handler for Windows applications already registered"
else
echo -n $"Registering binary handler for Windows applications: "
/sbin/modprobe binfmt_misc &>/dev/null
echo ':windows:M::MZ::/usr/bin/wine:' >/proc/sys/fs/binfmt_misc/register || :
echo ':windowsPE:M::PE::/usr/bin/wine:' >/proc/sys/fs/binfmt_misc/register || :
RETVAL=$?
[ $RETVAL -eq 0 ] && success || failure
fi
echo
}
stop() {
echo -n $"Unregistering binary handler for Windows applications: "
echo "-1" >/proc/sys/fs/binfmt_misc/windows || :
echo "-1" >/proc/sys/fs/binfmt_misc/windowsPE || :
RETVAL=$?
[ $RETVAL -eq 0 ] && success || failure
echo
}
wine_status() {
if [ -e /proc/sys/fs/binfmt_misc/windows ]; then
echo $"Wine binary format handlers are registered."
return 0
else
echo $"Wine binary format handlers are not registered."
return 3
fi
}
case "$1" in
start)
start
;;
stop)
stop
;;
status)
wine_status
RETVAL=$?
;;
restart)
stop
start
;;
reload)
stop
start
;;
condrestart|try-restart)
if [ -e /proc/sys/fs/binfmt_misc/windows ]; then
stop
start
fi
;;
*)
echo $"Usage: $prog {start|stop|status|restart|reload|try-restart}"
exit 1
esac
exit $RETVAL

View File

@ -0,0 +1,13 @@
<!DOCTYPE Menu
PUBLIC '-//freedesktop//DTD Menu 1.0//EN'
'http://standards.freedesktop.org/menu-spec/menu-1.0.dtd'>
<Menu>
<Name>Applications</Name>
<Menu>
<Name>wine-wine</Name>
<Directory>Wine.directory</Directory>
<Include>
<Category>X-Wine</Category>
</Include>
</Menu>
</Menu>

2972
wine-7.3-1.el8.src/wine.spec Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,5 @@
# Pre-PE Windows Executables
:windows:M::MZ::/usr/bin/wine:
# PE Windows Executables
:windowsPE:M::PE::/usr/bin/wine: