107 lines
3.9 KiB
RPMSpec
107 lines
3.9 KiB
RPMSpec
# Disable automatic bytecompilation. We install only one script and we will
|
|
# never "import" it.
|
|
%undefine py_auto_byte_compile
|
|
|
|
Name: python-rpm-generators
|
|
Summary: Dependency generators for Python RPMs
|
|
Version: 6
|
|
Release: 3%{?dist}
|
|
|
|
# Originally all those files were part of RPM, so license is kept here
|
|
License: GPLv2+
|
|
Url: https://src.fedoraproject.org/python-rpm-generators
|
|
# Commit is the last change in following files
|
|
Source0: https://raw.githubusercontent.com/rpm-software-management/rpm/102eab50b3d0d6546dfe082eac0ade21e6b3dbf1/COPYING
|
|
Source2: pythondist.attr
|
|
Source4: pythondistdeps.py
|
|
|
|
BuildArch: noarch
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%package -n python3-rpm-generators
|
|
Summary: %{summary}
|
|
Requires: python%{python3_pkgversion}-setuptools
|
|
|
|
%description -n python3-rpm-generators
|
|
%{summary}.
|
|
|
|
%prep
|
|
%autosetup -c -T
|
|
cp -a %{sources} .
|
|
|
|
%install
|
|
mkdir -p %{buildroot}%{_rpmconfigdir}
|
|
mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
|
|
install -Dpm0644 -t %{buildroot}%{_rpmconfigdir}/fileattrs pythondist.attr
|
|
install -Dpm0755 -t %{buildroot}%{_rpmconfigdir} pythondistdeps.py
|
|
|
|
%files -n python3-rpm-generators
|
|
%doc COPYING
|
|
%{_rpmconfigdir}/fileattrs/pythondist.attr
|
|
%{_rpmconfigdir}/pythondistdeps.py
|
|
%exclude %{_rpmconfigdir}/*.pyc
|
|
%exclude %{_rpmconfigdir}/*.pyo
|
|
|
|
%changelog
|
|
* Tue Jan 15 2019 Tomas Orsava <torsava@redhat.com> - 6-2
|
|
- Modifying python-rpm-generators from F29 to be used in RHEL7
|
|
- The regex in pythondist.attr has been modified to only match Python 3
|
|
modules, so that we do not affect the building of python2 files in RHEL7 at
|
|
this late stage
|
|
- Removed python.attr and pythondeps.sh files, because they are contained in
|
|
rpm-build in RHEL7 and we do not want to modify them
|
|
- the pythondist.attr and pythondistdeps.py are completely new, therefore we
|
|
don't need to conflict with anything in RHEL7
|
|
Resolves: rhbz#1660578
|
|
|
|
* Wed Oct 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6-1
|
|
- Tighten regex for depgen
|
|
|
|
* Sat Jul 28 2018 Miro Hrončok <mhroncok@redhat.com> - 5-4
|
|
- Use nonstandardlib for purelib definition (#1609492)
|
|
|
|
* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 5-3
|
|
- Add pythondist generator
|
|
|
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Sun Feb 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 5-1
|
|
- Fork upstream generators
|
|
- "Fix" support of environment markers
|
|
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.14.0-2.1
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Tue Nov 28 2017 Tomas Orsava <torsava@redhat.com> - 4.14.0-2
|
|
- Switch bootsrapping macro to a bcond for modularity
|
|
|
|
* Fri Oct 20 2017 Tomas Orsava <torsava@redhat.com> - 4.14.0-1
|
|
- Rebase to rpm 4.14.0 final (http://rpm.org/wiki/Releases/4.14.0)
|
|
- Re-synchronize version/release macros with the rpm Fedora package
|
|
|
|
* Mon Sep 18 2017 Tomas Orsava <torsava@redhat.com> - 4.14.0-0.rc1.1
|
|
- Update to a new upstream version of RPM
|
|
- Drop upstreamed patches
|
|
- Renumber remaining patches
|
|
|
|
* Thu Aug 24 2017 Miro Hrončok <mhroncok@redhat.com> - 4.13.0.1-4
|
|
- Add patch 10: Do not provide pythonXdist for platform-python packages (rhbz#1484607)
|
|
|
|
* Tue Aug 08 2017 Tomas Orsava <torsava@redhat.com> - 4.13.0.1-3
|
|
- Add patch 9: Generate requires and provides for platform-python(abi)
|
|
(https://fedoraproject.org/wiki/Changes/Platform_Python_Stack)
|
|
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.13.0.1-2.1
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Thu May 18 2017 Tomas Orsava <torsava@redhat.com> - 4.13.0.1-2
|
|
- Added a license file
|
|
- Added a dependency on rpm for the proper directory structure
|
|
- Properly owning the __pycache__ directory
|
|
|
|
* Tue May 02 2017 Tomas Orsava <torsava@redhat.com> - 4.13.0.1-1
|
|
- Splitting Python RPM generators from the `rpm` package to standalone one
|